0

I'm using pop-os 19.10 with gnome 3.34.2 and whenever I try to launch libreoffice(version 6.3.4) I get this error: /usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /lib/x86_64-linux-gnu/libcairo.so.2: undefined symbol: FT_Get_Var_Design_Coordinates

I tried removing ~/.config/libreoffice.

I tried uninstalling and reinstalling libreoffice from the pop!_shop and with these commands:

sudo apt-get --purge remove libreoffice-core

sudo apt-get install libreoffice

I also downloaded .appimage of two older versions(5.4.0 and 6.2.8). It gives the same error when I try to run them.

When I run any them with sudo it works. However this "locks" the files I'm working on since it changes the owner of the file to root every time I save. Thanks in advance!

1

It seems obvious that libcairo version is not compatible with the version of libreoffice you have. If your distro has only one version of those available, then I would recommend filling a bug. But maybe you're using some unofficial repositories which pulled wrong version into your system?

  • No, I don't think I'm using any unofficial repositories. How can I check the version of libcairo? – obblee Jan 25 at 22:53
  • Check out this: askubuntu.com/questions/428772/… However, I don't think you should care about the version. Package maintainers should take care about compatibility of the packages. – mkkot Jan 25 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.