13

My wife and I downloaded PDF museum passes and printed them on the same PostScript laser printer. To my surprise, hers looked much better! On the left is the printout from her Mac, and on the right the one sent from my Debian Linux machine. I am using evince 3.14.1, libcairo2 1.15.8, cups 2.1.3, and the Internet Printing Protocol to talk to the H-P LaserJet Pro 400 MFP M425dn (any other factor that could matter?).

Apparently, the printer is somehow not executing the PostScript content, which should yield a high-resolution rendering. But I am not aware of requiring that the content be pre-rendered on my desktop nor would I seek that.

What have I got set up wrong and how can I increase the output quality?

Print samples

  • 1
    Seems like a valid question, not sure why it was downvoted. You may want to check for an updated printer driver and/or ensure you are using a driver that matches the actual printer rather than a generic one. – jesse_b Jan 25 at 18:43
  • 2
    @jesse_b thanks. If I am not mistaken, using IPP and PostScript means I don't need a special driver at all. I have clarified this in the question. – Aaron Brick Jan 25 at 18:56
  • 2
    @jesse_b From my reading, IPP does not alter the data stream, it is a vehicle for sending documents -- but I am open to alternatives. – Aaron Brick Jan 25 at 19:13
  • 1
    It's been a while since I used cups but I remember we would only use ipp when no other print driver would work because of the quality issue. – jesse_b Jan 25 at 19:14
  • 3
    @jesse_b your comments are neither useful nor true. perhaps you are mistaking "IPP" (which was invented some time after the web) for "LPR" (which is ancient) or perhaps your account has been stolen by a troll. – Jasen Jan 26 at 6:19
8

Solved it. The pages were being rendered on the computer because I had chosen a LaserJet driver from the Hewlett-Packard section of the CUPS printer management interface, implemented using Gutenprint. This worked fine for B&W text but poorly for color areas.

After still not seeing a "PostScript" option in the configurator, I chose "Raw", and this works: now the rendering happens in the printer, making the paper output look proper with both graphics and text. Thanks to all for your help!

|improve this answer|||||
  • Thanks for letting us know! – fpmurphy Jan 27 at 4:02
2

Seems you might need to install HPLIP proprietary driver plugin:

https://developers.hp.com/hp-linux-imaging-and-printing/models/laserjet/hp_laserjet_400_mfp_m425dn

|improve this answer|||||
  • 1
    +1. I agree that the H-P site says HPLIP is required, but I think the fact that the printer understands PostScript Level 3 means it is not actually needed. I can print now without HPLIP so I am skeptical that it is the only way forward. – Aaron Brick Jan 25 at 23:16
  • @AaronBrick: It's not uncommon to be able to print with the wrong driver, it is common that you will encounter all sorts of printing issues with the wrong driver. Including the one you are seeing. – jesse_b Jan 25 at 23:45
  • 1
    PostScript support is itself the reason not to use HPLIP in this application. I would not have bought a PostScript supporting printer if I were going to render pages in software. – Aaron Brick Jan 26 at 5:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.