I'm running tests that require some files to be heavily fragmented. I came up with a method to generate fragmented files, but something is working in the background to defragment them. I'm using hdparm --fibmap and I see it start out with thousands of fragments, then a lot of disk IO later, I see it have under a hundred fragments.

Is it possible to disable this?


Ext4 doesn't "defragment" file's in the background. At most it will delay block allocation and then merge writes to the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.