I have a desktop PC with dual boot, which had the following setup:

  • SSD

    • EFI System Partition
    • Windows 10 system
    • Debian 10 encrypted root
    • Assorted recovery and backup partitions
  • HDD

    • EFI System Partition
    • Windows 10 data
    • Debian 10 encrypted home
    • More recovery and backup partitions
  • USB drive

    • EFI System Partition
    • Boot partition

When the USB drive was present, the PC would boot from it, launching GRUB and then Debian by default. Without the removable drive, the SSD's EFI partition would launch Windows Boot Manager directly, as if Debian was not installed. This was the ideal behaviour for my needs.

However, when reinstalling Debian Buster, with the exact same configuration as before, with the same partitions and the same USB drives for installation media and boot drive, the PC no longer boots Debian after installation. If I press F12 during the splash screen, the EFI partitions on the SSD and HDD will show up, but the one in the boot USB won't.

Things I've tried:

  1. Installing with another installation drive
  2. Another boot drive.
  3. Another USB port for the boot drive
  4. Wiped the boot drive before reinstalling
  5. Tried the text-based installer

I'm not sure what might have changed in the install process, since I've used the same installation media on various computers (and a couple times on the problematic PC) without issue. Only when installing through the text interface, I got the following error:

Attempt to mount a file system with type vfat in SSI1(0,0,0),partition#1(sda)at/boot/efi failed

This made me suspect the error didn't show on the graphical install and perhaps the USB was damaged. So I moved the partitions by 1GB and still can't boot from the USB drive.

Additionally, all the searches I've tried only refer to devices no longer booting long after installation.

Is there any condition which could have changed the behaviour of the installer, preventing it from making the drive bootable? Or maybe a bug in the installer or the EFI implementaion?


1 Answer 1


After many tries, I've worked around the issue.

The Debian installer (in EFI mode) has a bug (not sure if intermittent) resulting in EFI partitions not being bootable.

So, I installed Ubuntu 18.04 directly to the external USB (preserving the ESP) and afterwards retried the Debian installation. This time, Debian could boot directly from the USB drive as intended.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .