1

I'm porting this over from the Ubuntu SE, since I'm leaning more toward this being a general linux issue.

I saw another post on Ubuntu that had been removed by the moderator on this very same issue. This is a problem, and it seems oriented around linux.

Most of what I've found via google is very sparse and unhelpful.

Are there known issues with streaming CBS All Access with linux/ubuntu?

All I know is: when I used chrome dev tools to try to figure out what was going on; Widevine kept spitting out 400 Bad Request responses from their servers. Nothing seemed amiss as to what was being sent out. All of the proper DRM variables were being sent - yet CBS's servers kept kicking back a 400. So ... I come to you guys.

Aside from the nothing that is out there on the web; is anybody aware of known issues with CBS AA and Linux DRM streaming?

Thank you to anybody who has any information

  • To everybody that downvoted this question - root over here understood the question, and gave reliable feedback with an answer that fixed the issue. Just because you got all butthurt from Ubuntu SE and decided to carry your downvote over here as well doesn't mean my question is not valid. It's just a testament to how lame the SE community has become. The downvote squad mentality that SE communities are riddled with is exactly why people hate this place. How lame of you to follow the re-post just to downvote. Seriously. +10 for @root ... thank you man for not being one of them. – CreationTribe Jan 24 at 9:50
2

I can't really give you much more information other then a confirmation of the same issue on half a dozen different Linux builds I tried today. I've been using CBS AA since 2017 and it's always worked for me, last tried to use a couple months ago no problem. Today, same problem as you. Doesn't appear to be a User Agent block that is sometimes the case with these, nor a Chrome/Widevine or Firefox version block (tried the same versions on Windows VM without issue). I don't have a proper solution, other then if you have Amazon Prime, you can sign up for CBS All Access through Amazon Prime Video with a trial and same price, and it uses Amazon's video streamer - which works no problem on Linux browsers. There's a Reddit thread stating this issue goes back at least a couple weeks FWIW.

|improve this answer|||||
  • Wow man, thank you for that insight. Seriously. I guarantee the two down-votes on this post are just from people from the Ubuntu SE that saw the link I posted and flew over to downvote this as well - nevermind that this is actually an issue. I swear the StackOverflow DV squad mentality is a toxin around here. So thank you - honestly. I really do appreciate the info :) – CreationTribe Jan 24 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.