0

While adding brushes to GIMP I got this message:

Could not open '/home/mycrap/snap/gimp/227/.config/GIMP/2.10/brushes/bolts1_HMS.abr' for reading:
Error opening file /home/mycrap/snap/gimp/227/.config/GIMP/2.10/brushes/bolts1_HMS.abr: Permission denied

I have ownership over those directories so I don't know why GIMP can't access them.

I'm using Ubuntu 18.04

1
  • Based on the pathnames, I'm assuming you installed GIMP as a snap? if so, please edit your question to include the output of snap connections gimp Commented Jan 24, 2020 at 0:36

1 Answer 1

0

I tried to reproduce that issue, but for me downloading a Brush Archive and extracting it to the desired location worked just fine.

Hence I think that answering the question requires some additional information. I do not have enough reputation to comment yet, hence I write this as an answer even though I primarily ask for additional information.

  • Which method of adding brushes do you use for GIMP (provided you use a method which is different from what I did above)
  • are you absolutely sure that you own the files and that the path exists?

You could try

sudo chown -R $(whoami):users ~/snap/gimp/
chmod -R u+r ~/snap/gimp

in order to make sure that the directory is owned by you and you possess the rights to read contained files, but I think that is a bad idea. I would not override the default permissions for the entire directory recursively as done by the aforementioned command, but to check the permissions and rights added to the specific files:

ls -la /home/mycrap/snap/gimp/227/.config/GIMP/2.10/brushes/bolts1_HMS.abr

This should be something like

-rw-r--r--  1 [YOUR USER NAME] users

esp. have read rights granted to user, group and others.

Therefore I would appreciate if you could provide the output of

ls -la /home/mycrap/snap/gimp/227/.config/GIMP/2.10/brushes/bolts1_HMS.abr

and maybe also information on the user which launched gimp via

ps aux | grep gimp

I hope I do not offend you in any way by asking you to recheck the permissions, it is hard to guess the level of experience and as this seems to be a straight-forward permission problem I think it is best to double-check.

7
  • @steeldriver I did <sudo nautilus> but all the GIMP and Inkscape files are locked and can not change permission. I finally had to make a folder in home directory named brushes and shared the fonts system-wide. Installed via Flatpak.
    – crf
    Commented Jan 24, 2020 at 7:30
  • Though I would not recommend launching GUI applications as root, this indicates that there are some issues with permissions or ownership. Could you provide the output of ls -la /home/mycrap/snap/gimp/227/.config/GIMP/2.10/brushes/bolts1_HMS.abr and ls -la /home/mycrap/snap/gimp/ if the former command fails due to missing 'execute' permissions for the directories for your user? Commented Jan 24, 2020 at 11:30
  • // mycrap@MYCRAP:~$ ls -la /home/mycrap/snap/gimp/227/.config/GIMP/2.10/brushes/bolts1_HMS.abr -rwxrwxrwx 1 root root 1079094 Nov 18 07:36 /home/mycrap/snap/gimp/227/.config/GIMP/2.10/brushes/bolts1_HMS.abr mycrap@MYCRAP:~$ ls -la /home/mycrap/snap/gimp/ total 16 drwxr-xr-x 4 mycrap mycrap 4096 Jan 23 15:11 . drwxr-xr-x 5 mycrap mycrap 4096 Jan 23 16:24 .. dr-xr-xr-x 4 mycrap mycrap 4096 Jan 23 15:11 227 drwxr-xr-x 3 mycrap mycrap 4096 Jan 23 15:11 common lrwxrwxrwx 1 mycrap mycrap 3 Jan 23 15:11 current -> 227 mycrap@MYCRAP:~$
    – crf
    Commented Jan 24, 2020 at 14:53
  • sudo chown -R $(whoami):mycrap /home/mycrap/snap/gimp/227/.config should fix your issue, even though the permissions seem somewhat unusual. Commented Jan 24, 2020 at 15:01
  • I need access to these files to add fonts, extensions, and other addons. First time I have had this issue, been using thee programs for 10 years on Windows, just migrated to Linux most recently.
    – crf
    Commented Jan 24, 2020 at 15:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .