1

when issuing the command dnf upgrade on centos 8 I receive the following:

Error:
 Problem 1: package net-snmp-perl-1:5.8-7.el8.2.x86_64 requires net-snmp-agent-libs(x86-64) = 1:5.8-7.el8.2, but none of the providers can be installed
  - cannot install both net-snmp-agent-libs-1:5.8-10.el8.x86_64 and net-snmp-agent-libs-1:5.8-7.el8.2.x86_64
  - cannot install both net-snmp-agent-libs-1:5.8-7.el8.2.x86_64 and net-snmp-agent-libs-1:5.8-10.el8.x86_64
  - cannot install the best update candidate for package net-snmp-perl-1:5.8-7.el8.2.x86_64
  - cannot install the best update candidate for package net-snmp-agent-libs-1:5.8-7.el8.2.x86_64
 Problem 2: package net-snmp-gui-1:5.8-7.el8.2.x86_64 requires net-snmp-perl(x86-64) = 1:5.8-7.el8.2, but none of the providers can be installed
  - package net-snmp-perl-1:5.8-7.el8.2.x86_64 requires net-snmp-libs(x86-64) = 1:5.8-7.el8.2, but none of the providers can be installed
  - cannot install both net-snmp-libs-1:5.8-10.el8.x86_64 and net-snmp-libs-1:5.8-7.el8.2.x86_64
  - cannot install both net-snmp-libs-1:5.8-7.el8.2.x86_64 and net-snmp-libs-1:5.8-10.el8.x86_64
  - cannot install the best update candidate for package net-snmp-libs-1:5.8-7.el8.2.x86_64
  - cannot install the best update candidate for package net-snmp-gui-1:5.8-7.el8.2.x86_64
 Problem 3: problem with installed package net-snmp-perl-1:5.8-7.el8.2.x86_64
  - package net-snmp-perl-1:5.8-7.el8.2.x86_64 requires net-snmp-agent-libs(x86-64) = 1:5.8-7.el8.2, but none of the providers can be installed
  - cannot install both net-snmp-agent-libs-1:5.8-10.el8.x86_64 and net-snmp-agent-libs-1:5.8-7.el8.2.x86_64
  - cannot install both net-snmp-agent-libs-1:5.8-7.el8.2.x86_64 and net-snmp-agent-libs-1:5.8-10.el8.x86_64
  - package net-snmp-1:5.8-10.el8.x86_64 requires net-snmp-agent-libs(x86-64) = 1:5.8-10.el8, but none of the providers can be installed
  - cannot install the best update candidate for package net-snmp-1:5.8-7.el8.2.x86_64
 Problem 4: problem with installed package net-snmp-gui-1:5.8-7.el8.2.x86_64
  - package net-snmp-gui-1:5.8-7.el8.2.x86_64 requires net-snmp-perl(x86-64) = 1:5.8-7.el8.2, but none of the providers can be installed
  - package net-snmp-perl-1:5.8-7.el8.2.x86_64 requires net-snmp-libs(x86-64) = 1:5.8-7.el8.2, but none of the providers can be installed
  - cannot install both net-snmp-libs-1:5.8-10.el8.x86_64 and net-snmp-libs-1:5.8-7.el8.2.x86_64
  - cannot install both net-snmp-libs-1:5.8-7.el8.2.x86_64 and net-snmp-libs-1:5.8-10.el8.x86_64
  - package net-snmp-utils-1:5.8-10.el8.x86_64 requires net-snmp-libs(x86-64) = 1:5.8-10.el8, but none of the providers can be installed
  - cannot install the best update candidate for package net-snmp-utils-1:5.8-7.el8.2.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Any clue on what I can do about this issue without having to use --allowerasing and --skip-broken as I am trying to understand what the message means, but unfortunately I can't tell which package is causing this issue.

I also noticed this:

[root@localhost ~]# yum list installed | grep snmp

Modular dependency problems:

 Problem 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-MySQL:4.046:8010020191114030811:073fa5fe-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020191114033549:073fa5fe-0.x86_64
 Problem 3: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020191113222731:16b3ab4d-0.x86_64
net-snmp.x86_64                                    1:5.8-7.el8.2                                     @okay
net-snmp-agent-libs.x86_64                         1:5.8-7.el8.2                                     @okay
net-snmp-gui.x86_64                                1:5.8-7.el8.2                                     @okay
net-snmp-libs.x86_64                               1:5.8-7.el8.2                                     @okay
net-snmp-perl.x86_64                               1:5.8-7.el8.2                                     @okay
net-snmp-utils.x86_64                              1:5.8-7.el8.2                                     @okay
pcp-pmda-snmp.x86_64                               4.3.2-2.el8                                       @AppStream
snmptt.noarch                                      1.4-1.7                                           @@commandline

also this:

[root@localhost ~]# rpm -qa | grep snmp
net-snmp-agent-libs-5.8-7.el8.2.x86_64
net-snmp-perl-5.8-7.el8.2.x86_64
net-snmp-utils-5.8-7.el8.2.x86_64
net-snmp-5.8-7.el8.2.x86_64
pcp-pmda-snmp-4.3.2-2.el8.x86_64
snmptt-1.4-1.7.noarch
net-snmp-libs-5.8-7.el8.2.x86_64
net-snmp-gui-5.8-7.el8.2.x86_64

thanks

1 Answer 1

0

Edit 8th June 2020: I filed a bug on Redhat because I have a premium support, bug #1773441. Redhat is no longr building net-snmp-perl, so I think net-snmp-perl 1:5.8-12.el8_1.1 will be available soon.

I found the problem, it seems that net-snmp-perl-1:5.8-10.el8 doesn't exist for Centos 8, why installing net-snmp-perl, it downgrades these packages to 1:5.8-7.el8. Apparently it was a bad idea going with Centos 8 this time. There are many missing packages that I had to manually install, such as snmptt, any idea how one can request this package to become available for Centos 8

=======================================================================================================================================================
 Package                                    Architecture                  Version                               Repository                        Size
=======================================================================================================================================================
Upgrading:
 net-snmp                                   x86_64                        1:5.8-10.el8                          AppStream                        353 k
 net-snmp-agent-libs                        x86_64                        1:5.8-10.el8                          AppStream                        751 k
 net-snmp-utils                             x86_64                        1:5.8-10.el8                          AppStream                        238 k
 net-snmp-libs                              x86_64                        1:5.8-10.el8                          BaseOS                           822 k
Removing dependent packages:
 net-snmp-perl                              x86_64                        1:5.8-7.el8.2                         @okay                            1.2 M

Transaction Summary
=======================================================================================================================================================
Upgrade  4 Packages
Remove   1 Package
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.