0

I downloaded the latest version of Virtual Box, to run this virtual image of Kali Linux. I downloaded Kali Linux VirtualBox 64-Bit.

After I imported the OVA file to Virtual Box, some problems appeared about signing virtual box modules. I solve it by disabling secure boot instead of signing them. Which I know is wrong, but it's the easy way for now.

After that, the machine booted successfully, but after choosing the boot package I get a blackscreen. I try to solved it by increasing the Video Memory in Display settings but the problem is still there.

Any help? I use 18.04.1-Ubuntu, with Windows 10: multiboot option.

4
  • Have you tried to ssh into it from another computer to see if you can look at logs or just to see if it is actually still running? You may have to do an arp -a on another computer to get the ip address. (or any other way to get ip) If you can provide logs from the OS or possibly VirtualBox it will be easier for someone to help. Without more info your guess is as good as any. Also you may try the free version of VmWare Player to see if you have any luck. I have had issues with one and the other worked and vice versa. Jan 22 '20 at 13:20
  • I get the VM IP from here: unix.stackexchange.com/questions/350913/… , I tried to ping it but no response is there: 100% packet loss. also, I tried to debug it using VBoxManage but errors appear. I really don't know where the problem could be. I will try VMWare, thank you! Jan 23 '20 at 14:10
  • in my case , I was at a black screen after I enter my login and pass , in a GUI welcome screen. It all worked out when I changed from "Default session" to "Xfce session" , on that very same GUI login screen, from the top bar Oct 10 '20 at 20:57
  • There is a recent suggestion that the SecureBoot is actually required for VirtualBox to work under Ubuntu 20.04. Don't know how valid the claim is, though. Nov 13 '20 at 18:56
0

make sure that hardware virtualization or VT is enabled from your bios:

  1. reboot your computer.
  2. Look for instructions (on the bottom of the screen) on how to enter bios settings
  3. In the settings look for VT or hardware virtualization, enable it, save and quit.

If none of the above fixed the issue for you then right click the virtual machine name from virtual box, go to settings > General and make sure that the type is set to ​Linux ​and version is set to ​Debian 64 ​or ​Debian 32 depending on the Kali version you downloaded.

enter image description here

1
  • I did all of this. however, the problem still there. Jan 23 '20 at 13:43
0

Happens with me , I just boot in recovery mode and did this

apt --fix-broken install
0

FTR for me, it turned out that booting with an older kernel worked. brilliant, so the last upgrade to the latest kernel somehow blew my kali VM.

0

Found a working solution HERE.

Quoting:

Turning off Hyper-V from programs and features wasn’t enough. The below command worked as many others have used as well. Virtualization security in msinfo32 needs to be disabled and this is the only way I got it to work.

Enter this command: bcdedit /set hypervisorlaunchtype off

Enter this command: shutdown -s -t 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.