I have a One Netbook 1s running Xubuntu. Everything works find except the touch screen does not work after suspend. I have seen several people with similar problems and it seems like there is a potential solution in this link:


However, I do not understand the discussion there or what I am supposed to do with the material on github. I have tried a few solutions posted by people using Manjaro but they didn't work, perhaps because of the difference between Manjaro and Ubuntu...

This is a "Goodix" touchscreen. I am at the latest version of Ubuntu.

1 Answer 1


Update: You could try to do this. It worked for me. Note that you need to disable secure boot in bios to be able to run the script.

  1. Install acpi_call package (sudo apt install acpi-call-dkms for Debian/Ubuntu, sudo pacman -S acpi_call-dkms for Arch). For Fedora you can install this module from tlp repo. https://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html

The kernel module provided by this package is mandatory to get the touch screen working after suspend (the folks at Onemix did not define any GPIO in their DSDT related to the goodix reset lines, but rather directly implemented a reset method in the DSDT, that we can call using the acpi_call kernel module). Remember to load the module via: "sudo modprobe acpi_call"

  1. Create a new file /lib/systemd/system-sleep/goodixtouchscreen and put these contents :
    case $1 in
        modprobe -r goodix
        exit 0
        modprobe -r goodix || true
        sleep 1s
        echo '\_SB.PCI0.I2C2.TCSE.INTO 0' > /proc/acpi/call
        sleep 1s
        modprobe goodix
        exit 0

  • Hm that does not seem to be working. I made a file and copy-pasted the code you wrote. I installed the acpi package and loaded the module before making it sleep. Touch wasn't working after waking up. I rebooted, loaded the module, and made it sleep. Touch wasn't working then either. Jan 31, 2020 at 13:59
  • Actually it does work! I just forgot to change the permissions of the file (mark as executable)! Thanks! Jan 31, 2020 at 14:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .