2

I am on Debian bullseye, and I use GNU Icecat as my main browser.

It is my favorite browser, but it irks me that its time zone is always UTC, though I am in a different one. I see this because some websites detect my browser's time zone and compare it with the account time zone.


I tried running it while passing an environment variable:

TZ='US/Pacific' icecat

I ran the following in the JS Console:

new Date().getTimezoneOffset();

The offset returned by IceCat is always 0. Firefox returns it as per the time zone, but I am not sure how - it doesn't seem to obey the TZ variable either.


Is this a bug with Icecat itself? A privacy-preservation measure? A configuration error? The Debian package? I don't think it's the Debian package, because it was not installed via APT.

In any case, I would like to have the proper time zone returned. How do I fix it?

In case it's relevant, my build version is 60.3.0esr (64-bit).

5

To report the correct timezone, go to about:config and toggle privacy.resistFingerprinting to false then restart. So yes, this does appear to be a privacy-preserving measure.

Note that togging the setting will immediately affect calls to new Date().toString() in all tabs making them show the correct timezone, but new Date().getTimezoneOffset() doesn't appear to report the correct offset in all tabs until after restarting.

See this discussion on the Icecat mailing list.

2
  • Thanks! I will also search the mailing list from now on, and maybe post what I think is worth it over. – danuker Apr 30 '20 at 21:19
  • unfortunately it doesn't seem to work on IceCatMobile – Matija Nalis Nov 12 '20 at 4:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.