9

In my Crunchbang installation with X11, openbox, my wireless usb mouse is listed at both /dev/psaux and /dev/input/mouse0. It's working fine apart from the scroll wheel, which although active, is far too sensitive.

I'm thinking maybe the kernel is raising double the scroll events that it should be? Not sure what to check out even if this is the case?

I tried adjusting sensitivity via lxinput but it affected everything on the mouse apart from the actual scrollwheel.

xinput list

⎡ Virtual core pointer                              id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                    id=4    [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v2.0    id=9    [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v2.0    id=10   [slave  pointer  (2)]

doing

  • xinput test 9 results in expected mouse motion events (but nothing for button clicks/scrollwheel)
  • xinput test 10 results in unknown class with no events fired.
4
  • 2
    You can see what events X11 is getting by using xinput. In a terminal, do an xinput list to find the device id, then xinput test «device-id» to see all the events. (Control-C it to stop)
    – derobert
    Commented Nov 21, 2012 at 17:19
  • See also bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/619403
    – derobert
    Commented Nov 21, 2012 at 17:26
  • that bug refers to acceleration, the constant speed with mine is too fast. See updated xinput
    – citronic
    Commented Nov 21, 2012 at 17:58
  • @rutherford have you tried debugging it with xev ?
    – Darek
    Commented Feb 17, 2015 at 17:18

4 Answers 4

1

If it's a Microsoft mouse, try resetmsmice, which will fix this problem, without having to unplug and replug the mouse receiver. Many thanks to the author Paul F Richards, also the Ubuntu launchpad bug report

1

Try to increase Scrolling Distance to 3, 3, 3

xinput --set-prop 10 274 3, 3, 3
1

A script I wrote to cure 'jumpy mouse' -- disable_scroll

#!/bin/bash

id=$(xinput --list --id-only 'Logitech USB RECEIVER')
#usually "8" but sometimes "10" 

# so there are 24 different buttons possible (!)
# This will disable all the extra buttons
# use only the right, left and middle click.

/usr/bin/xinput set-button-map "${id}" \
1 2 3 0 0 0 \
0 0 0 0 0 0 \
0 0 0 0 0 0 \
0 0 0 0 0 0 
# end

even if you want scrolling disabling the extra button signals may help eliminate stray interrupts. I found additionally that using a USB extension cable to get the usb radio receiver away from the chassis improves the signal/noise ratio and the mousing is more responsive and smoother.

1

Create a file with name /etc/udev/hwdb.d/71-mouse-local.hwdb with something like this

# My mouse settings
mouse:usb:v093ap2510:*
   # MOUSE_DPI=600
   MOUSE_WHEEL_CLICK_ANGLE=10

This will target a mouse with usb id 093a:2510 or (v)093a(p)2510.

For more info and examples look at the file /lib/udev/hwdb.d/70-mouse.hwdb.

To apply the changes do

sudo systemd-hwdb update
sudo udevadm trigger /dev/input/eventXX
sudo udevadm info /sys/class/input/eventXX

get the event number from xinput. The above must be done only once.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .