0

I installed Linux Mint on my laptop. After I login, the screen goes completely dark and there is no output on the screen or anything. Same thing happened with Kubuntu also. Live-USBs worked fine.

  • 1
    Do you have any reason to suspect your internal hard disks as being faulty? Can you access them when using a Live USB? – Jeff Schaller Jan 20 at 11:18
  • Are you able to switch to terminal?: Ctrl+Alt+F3 – Gryu Jan 20 at 11:20
  • @Gryu At the login screen. Yes. Not after that. – Naveed Unjum Jan 20 at 11:25
  • @JeffSchaller I can access them using a Live USB. My file system is basically 128G SSD for the OS and 1 TB HDD. – Naveed Unjum Jan 20 at 11:26
  • Before log in switch to terminal and try to install other desktop manager (budgie, xfce) and proprietary video drivers if they are available. Also you could test installing system on hdd, but be careful to not destroy your valuable data. Back up it. – Gryu Jan 20 at 11:31
1

Try the following:
When in grub (If you can't see grub hold Shift while booting) select the Linux Mint option and press e. You should see a line that says something like this:

linux /boot/....... quiet splash

Then go at the end of the line and add nomodeset:

linux /boot/....... quiet splash nomodeset

Boot by pressing F10 or Ctrl+X.
If that fixes your problem you can then make it permanent. Open a terminal and type:

sudo nano /etc/default/grub

At the beginning of the file search for:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Once again add the nomodeset option:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Type Ctrl+X then y to save and exit. Update grub:

update-grub

If you get the error command not found use

grub-mkconfig -o /boot/grub/grub.cfg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.