0

I recently installed Debian onto my 3rd gen Thinkpad X1 Carbon and am having some issues with getting WiFi to work. I tried following quite a few different suggestions online and none seem to be helping me - here is some info about my machine and what I have done already. Bluetooth works perfectly.

Output of nmcli device:

DEVICE  TYPE     STATE       CONNECTION
enp0s25 ethernet unavailable --
lo      loopback unmanaged   --

And the response of lspci doesn't have a wireless controller inside. Ethernet Controller is Intel Corporation Ethernet Connection (3) I218-LM (rev 3).

Output of sudo dmesg | grep iwl is nothing.

I can't run modinfo because it isn't installed.

My computer has an Intel 7265 Wireless card, and I've tried downloading both the drivers from here - List of firmware in Linux kernel and dropping them into /lib/firmware, which didn't work for me. Nothing appeared to change.

I tried following this guide - Re: wifi not working on my new lenovo thinkpad x-1 but it requires installing software onto my laptop without internet, which I can't easily do. Keryx doesn't appear to be working anymore, and I can't install software with its dependencies onto my X1 Carbon effectively over bluetooth.

Any advice or suggestions?

1
  1. Download and install the firmware for your device's wireless adapter. If your device uses an Intel WLAN adapter, follow this guide.
  2. If your device isn't connected to the internet, the iwlwifi firmware can be installed without an internet connection:
    1. Download the iwlwifi firmware from here.
    2. Move the .deb file to your device.
    3. Install the file:
$ sudo dpkg -i /path/to/deb/file
$ sudo apt-get install -f
  1. Restart your machine. Internet should now work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.