2

I have several older Dell laptops and have been putting them to good use by installing Linux and BSD Unix. I wanted to learn OpenBSD Unix so I installed it on a Dell Vostro 1500 I have with 2Ghz Intel Dual Core Processor, 2GB RAM, and 120GB Hard drive. The install was no problem at all, a USB install using the fs file, and the default FVWM window manager works perfectly, but I was hoping to use Gnome with OpenBSD, like I do with two other dell laptops. I have one with Fedora Linux, and another with Kali Linux.

So I installed Gnome from the command line, as root using pkg_add, from the NYC OpenBSD Mirror. Gnome version 3.2 was installed, I also made sure to install all patches, before trying to install Gnome. And also installed gnome-extras.

Then I disabled xenodm using rcctl command, and enabled multicast messagebus avahi_daemon gdm, also with the rcctl command at the command line, as root. Then I rebooted, Gnome appears to run, but anytime I open up an application, all I get is a black screen, like in the photo, it is Gnome initial setup that is blacked out, also terminals and text editors are the same, all black. I was just curious if anyone had experienced the same problems? I have a second Dell Vostro 1500 laptop with Fedora Linux, and gnome works perfectly, same exact hardware as the OpenBSD dell laptop, also I have Kali Linux on a Dell e6400 laptop, and Gnome runs perfectly on that laptop also.

enter image description here

  • Which version of OpenBSD did you install? 6.6-stable (i.e. release + patches) or are you following -current? Recently, pango switched to harfbuzz, thus dropping the support for bitmap fonts and wreaking all sorts of havoc on many software that depends on it, GTK included (see this thread for reference). Which font are you using in your terminals? – Zé Loff Jan 18 at 22:49
  • I installed version 6.6 by usb with the .fs file, then did a syspatch after install, I think it would be the stable version, syspatch should make it current? right? – Michael G. Workman Jan 20 at 1:13
  • 1
    Not quite. Right after install you got 6.6-release. After running syspatch you ended up with 6.6-stable. To get -current you'll need to run sysupgrade, but with the -s switch (see man sysupgrade). – Zé Loff Jan 25 at 14:45
  • Ok, hey! great advice! thanks for sharing I will try this today to see if it fixes the bug. – Michael G. Workman Jan 26 at 17:50
  • Since this issue, I installed an SSD solid state hard drive on this laptop, and reinstalled OpenBSD 6.6, and did syspatch, and reinstalled Gnome, but still the same black screen issue. But ok, this laptop was a little slow with the standard disk hard drive, but now is running very fast with the SSD, it is a very big improvement, definitely. I am going to use SSD with all my computers now. – Michael G. Workman Jan 26 at 17:55
1

Ok this problem is now solved!!! The solution was to use sysupgrade -s, then the computer will reboot, upgrade, and reboot again, which upgrades to OpenBSD 6.6 -current, Then reenable gnome using rcctl commands, and disable xenodm using rcctl, and reboot, then Gnome works!

Also, very important, if you get an "ftp 404 not found" error while running the sysupgrade command, then change the /etc/installurl file to the following:

https://cdn.openbsd.org/pub/OpenBSD

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.