8

I had bluetooth working fine till today when I needed to add a USB storage device. The usb device didn't work, the system couldn't see it (lsblk didn't show anything). So tried rebooting the system. Before that I did pacman -Syu. Also I installed (later uninstalled virtualbox-ext-oracle) from AUR. Now the usb storage drive is seen by the system but bluetooth does not work. Could you help?


[I] ➜ sudo systemctl restart bluetooth.service bluetooth.target 

[I] ➜ systemctl | grep bluetoo                            
  sys-devices-pci0000:00-0000:00:14.0-usb1-1\x2d14-1\x2d14:1.0-bluetooth-hci0.device               loaded active plugged   /sys/devices/pci0000:00/0000:00:14.0/usb1/1-14/1-14:1.0/bluetooth/hci0                 
  sys-subsystem-bluetooth-devices-hci0.device                                                      loaded active plugged   /sys/subsystem/bluetooth/devices/hci0                                                  
  bluetooth.service                                                                                loaded active running   Bluetooth service                                                                      
  bluetooth.target                                                                                 loaded active active    Bluetooth                                                                              


[I] ➜ bluetoothctl 
Agent registered
[bluetooth]# power on
No default controller available
[bluetooth]# scan on
No default controller available
[bluetooth]# 

[I] ➜ sudo rmmod btusb    

[I] ➜ sudo modprobe btusb

[I] ➜ dmesg | grep Bluetooth
[   10.777582] Bluetooth: Core ver 2.22
[   10.777590] Bluetooth: HCI device and connection manager initialized
[   10.777592] Bluetooth: HCI socket layer initialized
[   10.777594] Bluetooth: L2CAP socket layer initialized
[   10.777595] Bluetooth: SCO socket layer initialized
[   11.329615] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   11.329615] Bluetooth: BNEP filters: protocol multicast
[   11.329618] Bluetooth: BNEP socket layer initialized
[   13.036936] Bluetooth: hci0: command 0xfc05 tx timeout
[   13.037031] Bluetooth: hci0: Reading Intel version information failed (-110)
[  779.744086] Bluetooth: hci0: Reading Intel version information failed (-110)
[  779.744091] Bluetooth: hci0: command 0xfc05 tx timeout
[ 2330.676540] Bluetooth: hci0: Reading Intel version information failed (-110)
[ 2330.676549] Bluetooth: hci0: command 0xfc05 tx timeout



[I] ➜ rfkill list
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

[I] ➜ pa -Qs blue
local/bluedevil 1:5.17.5-1 (plasma)
    Integrate the Bluetooth technology within KDE workspace and applications
local/bluez 5.52-2
    Daemons for the bluetooth protocol stack
local/bluez-libs 5.52-2
    Deprecated libraries for the bluetooth protocol stack
local/bluez-qt 5.66.0-1 (kf5)
    Qt wrapper for Bluez 5 DBus API
local/bluez-utils 5.52-2
    Development and debugging utilities for the bluetooth protocol stack
local/pulseaudio-bluetooth 13.0-3
    Bluetooth support for PulseAudio

[I] ➜ id
uid=1000(art) gid=1000(art) groups=1000(art),108(vboxusers),991(lp)

[I] ➜ uname -a
Linux artpc 5.4.12-arch1-1 #1 SMP PREEMPT Tue, 14 Jan 2020 21:44:31 +0000 x86_64 GNU/Linux

Update. Post at ArchLinux forum: https://bbs.archlinux.org/viewtopic.php?pid=1883397#p1883397

2
  • 1
    From archlinux thread I noticed your issue went away later. I experienced exact same dmesg output with machine which has Intel® Wi-Fi 6 AX200 after unexpected power loss. It did not recover after multiple soft reboots. Eventually I tried complete power off (including physical button on power supply) and it came back fine. Commented Jul 29, 2020 at 13:06
  • Same situation as Tadas. I had rebooted a few times, but after reading the comment I did as he said. Not enough, but I tried again even disconnecting the power supply and giving it half a minute, and turned it back on and everything worked again. Not gonna try to understand it, just happy it works again.
    – Mamsaac
    Commented Nov 18, 2021 at 17:03

3 Answers 3

10

I had the same issue on the 5.15.41 kernel and AX200. This resolved it for me:

sudo rmmod btusb
sudo rmmod btintel

sudo modprobe btintel
sudo modprobe btusb

Source: https://bbs.archlinux.org/viewtopic.php?id=271459

3
  • 1
    I'm on Linux 6.1.11 and this still fix the problem at the reboots when I have this problem
    – Cirelli94
    Commented Feb 19, 2023 at 17:05
  • Same here. I don't know how, but this is the only thing that fixes it.
    – Ananth
    Commented May 25, 2023 at 12:07
  • 6.1.31 still has this problem sometimes. It looks like hardware issue, the hardware is not getting ready soon enough, or something.
    – 9000
    Commented Jun 7, 2023 at 23:18
0

I am using USB Kali Linux (or) Live Kali Linux with kernel version 6.

Issue is hciconfig doesn't detect the bluetooth adapter , it shows me bdaddress:00:00:00:00:00. Command hciconfig hci0 up shows Operation not permitted(1)

After I tried all the above sort of things lot of browsing spend much more time than expert I finally resolved it by the steps below:

  • open terminal
  • type command sudo apt-get -y install inxi, then inxi -bE

This shows complete hardware details in your device. Here you can see Bluetooth address other than 00:00..., that is your system Bluetooth address.

  • use command hciconfig - here the bdaddress now changes
  • to start Bluetooth service again type commands
service bluetooth start
bluetoothctl
scan on

Here controller is registered with your Bluetooth hardware address.

Connect your Bluetooth device now.

0
sudo sh -c "modprobe -r btusb; sleep 2; modprobe btusb"

Source

One shouldn't need to do this, but it seems to do the magic.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .