12

Im trying to transfer a file using samba. I started a smbserver and can not connect to it.

Command: smbclient -L //ip address/temp

Error: protocol negotiation failed: NT_STATUS_NOT_SUPPORTED

1 Answer 1

24

In last release of Kali there is an issue I encountered too. In order to get smbclientto work you need to edit the SMB configuration file. And then at least mine worked.

I'm using vi to I edit the config file as follows:

vi /etc/samba/smb.conf

You need to add the following settings under GLOBAL:

client min protocol = CORE
client max protocol = SMB3
5
  • 2
    This helped me with my error: protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED on arch linux. Only upon adding the two lines, I was prompted for a password for the first time (and could log on).
    – Sebastian
    May 24, 2020 at 11:28
  • 2
    Can confirm this is also an issue in openSUSE Leap 15.2, and that adding these two lines immediately fixed the problem. However, upon some further reading, this enables the obsolete SMB1 protocol which decreases security for this part of the system. Mar 22, 2021 at 21:02
  • confirm: ubuntu server and router comtrend. It does not worked via parameters: -m SMB3, etc.
    – xerostomus
    Sep 3, 2021 at 19:04
  • Works also on Ubuntu 20.04.03 LTS desktop and Speedport Pro Plus router (Telekom germany) Feb 19, 2022 at 13:15
  • Confirmed solution on Parrot OS 5.3 Electro Ara (arm64)
    – ppseprus
    Jan 16 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .