I am trying to set up x11vnc with an Xubuntu 19.10 machine as the server and a Windows 10 Pro machine as the client. For some reason, when I connect to the x11vnc server, the VNC viewer opens up a connection to the terminal. This is not what I want; I want to be able to access the Xfce desktop. I can access the desktop on the Xubuntu machine itself, and I can type startxfce4 in the VNC session to get to an Xfce desktop, but I know there has to be an easier way. What is it?


2 Answers 2


Turns out that adding the -usepw flag allowed me to get to the Xfce desktop.


Welcome to the wonderful world of X11. There are several different ways to set up your X environment.

Option 1 is to use a display manager (lightdm, gdm, xdm, kdm) which automatically starts the X server, prompts you for your login info, and starts your X session which you can usually select. To get VNC running on display managers, see this.

Option 2 is xinit. xinit allows you to start your X session directly from the console with two files, ~/.xinitrc and ~/.xserverrc. To start Xfce4 using xinit with VNC enabled, create ~/.xinitrc and add the following commands:

x11vnc & # start VNC as a job
xfce4-session # start xfce4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .