0

As the description says, I want to set up an OpenVPN connection which is available through my Netgear R8500 router for use on my laptop which is running Pop!_OS. I don't think the fact that it's Pop!_OS specifically has any impact on the matter as it's based on Ubuntu 19.10.

I updated the firmware on my Netgear router and regenerated the OpenVPN certificate. I downloaded the configuration package for smart phones and set it up on my Android device as a test that the router is accessible through the internet and that I can connect. I'm able to access a computer running on my home network.

I then downloaded and extracted all 3 of the configuration packages (for Windows, for non-Windows, for Smartphone) to my laptop.

I have the openvpn, network-manager-openvpn, and network-manager-openvpn-gnome packages installed.

From the terminal openvpn --config [win|non-win|smart].ovpn runs without warnings or errors... but it never seems to do anything. There's no output at all and it doesn't seem to ever time out. I can still access the internet fine, but I'm not able to connect to a computer on my home network. I looked in /var/log/openvpn but there are no files in there. I also tried running the command with sudo.

I've also tried configuring the VPN through the network manager GUI by importing from file. I've tried all 3 of the configuration packages and they all have the same result. They go into a connecting state for a minute and then it errors out just with the message "Activation of network connection failed."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.