1

I recently installed Linux Mint 19.1 (Tessa) on a desktop with a wired connection behind a highly restrictive (ingress and egress) firewall. The only way to the Internet is through a proxy server that is allowed to transit the aforementioned firewall. I understand that Linux Mint 19.1 (Tessa) is derived from Ubuntu 18.04 LTS (Bionic).

Linux Mint 19.1 (Tessa) related issues:

1) Daemon "systemd-resolved" reported the error every five minutes, "Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP."

2) Daemon "NetworkManager" reported the error every five minutes, "info connectivity: (eno1) timed out."

3) Gnome Maps loaded but was unusable and reported the errors "Maps is offline!" and "Maps need an active internet connection to function properly."

For comparison, Linux Mint 18.0 (Sarah) behind the same restrictive firewall runs Gnome Maps without issue.

NetworkManager's Connectivity Check times out:

sudo nmcli networking connectivity check

Error: Timeout was reached.
1
  • If you have found a solution to your issue, then please consider posting this as an answer rather than as part of the actual question. It is perfectly ok to self-answer questions. This additionally makes it possible for you to "accept" your own answer later, which marks the issue as resolved.
    – Kusalananda
    Jan 13, 2020 at 8:53

1 Answer 1

-1

The workaround is to disable NetworkManager's Connectivity Check:

sudo nano /usr/lib/NetworkManager/conf.d/20-connectivity-ubuntu.conf

Change from the following:

uri=http://connectivity-check.ubuntu.com/

to the following:

#uri=http://connectivity-check.ubuntu.com/

-> Ctrl + o -> Enter -> Ctrl + x

sudo shutdown -r now

NetworkManager's Connectivity Check should now report full connectivity:

sudo nmcli networking connectivity check
full

Test Gnome Maps, and verify that it no longer reports "Maps is offline!".

I think NetworkManager's Connectivity Check was added to support captive portals, but I have no need for a captive portal. You will need to evaluate the need for yourself.

I spent several days troubleshooting this, and I hope it helps others.


Update (2020-04-07):

The issue with Gnome Maps and NetworkManager's Connectivity Check returned. I think a recent update to NetworkManager (network-manager-config-connectivity-ubuntu) replaced "/usr/lib/NetworkManager/conf.d/20-connectivity-ubuntu.conf" with a default configuration file, re-enabling Connectivity Check.

According to "Add NetworkManager connectivity config package", Option 2 is to create a new file that disables Connectivity Check: https://bugs.launchpad.net/network-manager/+bug/997200

sudo nmcli networking connectivity check
Error: Timeout was reached.

Create a new file and edit:

sudo nano /etc/NetworkManager/conf.d/20-connectivity-ubuntu.conf

Add the following:

[connectivity]
enabled=false

-> Ctrl + o -> Enter -> Ctrl + x

sudo shutdown -r now

sudo nmcli networking connectivity check
full

Hopefully, this method is more resistant to Update Manager.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .