1

For Python files, I must use spaces for indenting. My default Kate editor setting uses tabs. I don't want to change the default, but I want to configure the proper settings for Python files.

I found an answer here that gives the basic steps:

  1. In Kate Settings → Configure Kate → Editor Component → Open/Save → Modes & Filetypes.

  2. Therein, select your desired filetype, e.g. Scripts/Python.

  3. Click on the little tool-button next to the Variables line edit.

  4. In the dialog that opens, scroll down until you find:

    • replace-tabs-save
    • replace-tabs

In those options, I checked the box (to override the default setting) and selected true from the drop down list. I "OK'd" the changes and came back to editing my Python file. However, the changes I made are not having any effect.

What did I do wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.