1

I'm trying to set up a convenient compose key to use for practicing Greek in duolingo. But, I don't want it to mess up my normal use of my laptop. I'm a developer by trade and use pretty much all of the normal single key options shown in the "Position of Compose key" settings in Linux regularly on my laptop, with the exception of the Menu key. However, my new laptop doesn't have a menu key. :-P

So, I wanted to try the "3rd level of Caps Lock" or any of the "3rd level" settings (see screenshot below for the settings I'm talking about).

enter image description here

But...having tried one, I'm not sure how to actually use it. I've tried searching, but all the info I've found about "3rd level keys" is when using a key as a modifier (e.g., holding Caps Lock and a simultaneously to get some modifier of a). That's not working though.

If I use one of these "3rd level of X" settings...how do I actually use it? :)

For reference, my distro is Linux Mint 19.3 (Tessa) using Cinnamon. Which is based on Ubuntu 18.04.

1 Answer 1

2

You will reach the third level by holding "AltGr".

In order to compose e.g. "å" using "3rd level of Left Win" do the following:

press and hold "AltGr", press "Left Win", release both and press "a" twice.

3
  • Ok, so I was missing something here. I hadn't realized AltGr was a separate key...I thought that's what I was configuring in this dialog. But, I get now that AltGr is separate from setting up the compose key. It appears that AltGr is the right Alt by default. Your answer ALMOST works for me, but not quite. I can't release "AltGr" and "Left Win". I have to hold "AltGr" (right alt for me), "Left Win", and then without releasing those press the single quote (') followed by a to get ὰ. Not sure why it's working that way...but at least now I can type accented chars. So, I'll accept your answer.
    – stuckj
    Jan 10, 2020 at 20:40
  • Interesting, because if I don't release both keys I get no result at all and if I release AltGr only, I just get capital letters.
    – kim
    Jan 12, 2020 at 14:41
  • ¯_(ツ)_/¯ I'm just glad it works now. But, it does seem strange because I thought you were supposed to release the compose key to get it to work.
    – stuckj
    Jan 13, 2020 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.