2

First of all, the server specs:

VPS - OpenVZ, Ubuntu 14, Kernel 3.10

Now, it appears that the cron daemon is not running ANY crojobs at all and i cannot find out why.

I tried:

  • Rebooting the server.
  • Restarting the cron daemon
  • Changing permissions in /etc/crontab, /etc/cron.d, /etc/cron.daily and /var/spool/cron
  • Disabling one by one, the cron jobs from crontab, cron.d and spool ones.
  • Changing permission in /usr/sbin
  • Upgrading vixie cron
  • Removing the pam_loginuid.so in pam.d
  • Changing passwords around (to the ones I think were the first ones)
  • Tried making a cron job that outputs a logfile every minute in /etc/crontab file, user crontab and root crontab

and I still cannot find a solution.

NOTE: Whenever i changed permissions to files, I used another fresh Debian install for reference.

Also, there is this message that is being written to cron.log every minute and also, cannot find the source of it. Attaching image: cron.log

This is my last resort before doing a full system reinstall.

5
  • Does this help: stackoverflow.com/questions/43323754/… ? Specifically the workaround in the accepted answer.
    – Jos
    Jan 9, 2020 at 15:56
  • Thanks, but i already listed that as something i tried already to no avail
    – Homeroe
    Jan 9, 2020 at 16:02
  • 1
    Since Ubuntu 14 is end-of-life, is upgrading to 16.04 or 18.04 an option?
    – doneal24
    Jan 9, 2020 at 16:18
  • The server is old but heavy in traffic so, i'm kinda afraid of making the upgrade without breaking everything up. But if there is no other option left, guess i'll have to do it anyways.
    – Homeroe
    Jan 9, 2020 at 18:15
  • Related questions are unix.stackexchange.com/q/152098/5132 and unix.stackexchange.com/q/523365/5132 .
    – JdeBP
    Jan 9, 2020 at 20:16

1 Answer 1

0

I cannot comment as yet so I have to post this as an answer.

You didn't mentioned whether you checked your /var/log/auth.log file.

This error is usually caused by a pam module so this log should give you some hints.

1
  • The last 2k lines of that file are just failed SSH login attempts from random people trying to brute force and nothing else
    – Homeroe
    Jan 10, 2020 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.