0

When I run the command,

sudo pacman -Syu

I get a lot of errors like this:

error: could not read db 'core' (Can't parse line 1)
error: could not read db 'multilib' (Can't parse line 1)

And then at the end of it, says:

there is nothing to do

sudo pacman -Syu

How can I fix it?

1

I just received a similar error message, for me it occurred because I tried to run an update earlier in a network that required me to login. So somehow the HTML login page landed in my sync files for core, community, multilib here: /var/lib/pacman/sync/community.db

Simply check if a similar thing happened to you: $ cat /lib/pacman/sync/core.db

For me, simply removing these files was sufficient to fix the pacman issues. If you're unsure copy them to a safe location prior to that. $ sudo cp /lib/pacman/sync/core.db ~ $ sudo cp /lib/pacman/sync/multilib.db ~ $ ...

I guess there is also a pacman command for clearing the cache wich should work aswell.

  • 1
    Removing /var/lib/pacman/sync/community.db and the same file for multilib.db and core.db and then running sudo pacman-key --populate fixed it. – Amir A. Shabani Jan 16 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.