0

I recently installed Linux Mint 19.3, and the wifi works for a while after starting the computer up. But after some time, usually a couple hours of continued use, the wireless functionality just stops working, and the only way to get it working again is to do a complete restart.

Relevant system info from inxi:

Network:
  Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: e000 
  bus ID: 02:00.0 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 

Running iwconfig yields:

wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

enp3s0    no wireless extensions.

lo        no wireless extensions.

Additional info/things I've already tried:

  • Wired internet works just fine.
  • Restarting NetworkManager doesn't help, even after logging out and then back in. The only thing it changes is that both my network applet and inxi list wireless as up until I reset, at which point the state is down and the network applet says wireless is unavailable.
  • I've tried switching kernel versions, specifically to 5.0.0-37, 5.0.0-32, and 4.15.0-72 - the issue persists on all of them.
  • Nothing is getting blocked with rfkill (except Bluetooth, which I have turned off):
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
  • I've added the following to iwlwifi.conf to no avail:
options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8
options iwlwifi power_save=0
  • The firmware drivers I have installed for my card are:
iwlwifi-3160-10.ucode
iwlwifi-3160-12.ucode
iwlwifi-3160-13.ucode
iwlwifi-3160-14.ucode
iwlwifi-3160-16.ucode
iwlwifi-3160-17.ucode
iwlwifi-3160-7.ucode
iwlwifi-3160-8.ucode
iwlwifi-3160-9.ucode

(I tried installing 14 myself, but I assume it's not getting used since it's not the highest version number)

Any advice on how to troubleshoot this further?

0

Probably too late to answer, but may help others. I can't help with troubleshooting, but I had the same symptoms on a Fujitsu Laptop a couple of years ago, and resolved completely by changing from Network Manager to WICD. That was mint 18.3 XFCE. Available from std repo. Google instructions for permanently disabling NM.

I have since sorted another Fujitsu Laptop which was spamming logs to death by doing the same. Mint 19.3 XFCE.

  • Welcome to the site, and thank you for your contribution. If you found instructions for disabling nm that you found useful, maybe you could add a link to that page (and possibly summarize the necessary steps in your answer, as external links can become invalid or their content chang). – AdminBee Aug 18 '20 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.