0

I've installed nmap in my Mac OS X tried.

I'm not on Linux, I couldn't find the script directory. I ran

sudo nmap -sV --script vulners 69.164.220.111

Password:

I kept getting

Starting Nmap 6.49BETA4 ( https://nmap.org ) at 2020-01-07 14:35 EST
NSE: failed to initialize the script engine:
/usr/local/bin/../share/nmap/nse_main.lua:801: 'vulners' did not match a category, filename, or directory
stack traceback:
        [C]: in function 'error'
        /usr/local/bin/../share/nmap/nse_main.lua:801: in function 'get_chosen_scripts'
        /usr/local/bin/../share/nmap/nse_main.lua:1249: in main chunk
        [C]: in ?

QUITTING!

Do you know what I did wrong ?

0

according to nmap --help on my MacBook Air:

 --script=<Lua scripts>: <Lua scripts> is a comma separated list of
           directories, script-files or script-categories

so it looks like you need --script=vulners

1
  • Let me try thanks – cyb3rZ Jan 8 '20 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.