I have installed Kali linux version Linux DESKTOP-0667P5P 4.4.0-18362-Microsoft #476-Microsoft Fri Nov 01 16:53:00 PST 2019 x86_64 GNU/Linux as a subsystem on my machine that is running Windows 10, I't seems that I have installed the very basic version of Kali and I was trying to install the full version using this command sudo apt-get install kali-Linux-full, but I ran into the same error in this post.

I have tried the one and only answer posted there which is running the command

sudo mv /var/cache/apt/archives/jsql-injection_0.81-0kali2_all.deb \ /var/cache/apt/archives/jsql-injection_0.81-0kali2_all.deb.old

but it gives me the error of Permission Denied.

I've also tried running sudo apt-get clean but produces the error below:

Problem unlinking the file jsql-injection_0.81-0kali2_all.deb - pkgAcquire::Clean (13: Permission denied)

I am able to Log in to root using sudo su but it still gives me permission denied.

  • 1
    What exact command gives you that error? What version number of Windows and what version of Kali are you doing this with?
    – Alex V
    Jan 7, 2020 at 15:24
  • Thanks @Alex I have clarified my post a bit more I hope that helps. Jan 7, 2020 at 15:47
  • 1
    I know this is late! but this may help other with the same problem! i've got this fixed: This link could help : askubuntu.com/questions/772846/apt-get-update-unlinking Jan 20, 2020 at 13:45

1 Answer 1


Maybe your windows virusscanner is blocking it? I know I tried to install metasploit on Kali in WSL and my virusscanner went batshit crazy of all the exploit data. Which makes sense but I hadn't thought about it beforehand.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .