2

I recently upgraded from Debian Jessie to Stretch and had a hard time getting X to start due to graphics conflicts. I sorted those out through a series of purge and reinstall commands and was excited to see the familiar login screen. Unfortunately for me, after I enter my password, the screen briefly blinks and I'm still at the login screen.

I can get into the system without problem on one of the other TTY, but I can't seem to get the desktop to come up.

Other things of note:

  • I have checked the .Xauthority permissions/ownership and they are fine (as are the rest of the files in my home.)
  • It doesn't seem to matter which desktop I choose (I have Fluxbox, Gnome, and X11 options) it always comes right back.
  • The logs seem pretty clear, nothing stands out as suspect to me

Edit:
The Xorg.0.log has the following EE lines:

(EE) open /dev/dri/card0: No such file or directory
(EE) Screen 0 deleted because of no matching config section
(EE) AIGLX: reverting to software rendering

Edit2:
Home has 100G of free space, root has 2.4G

.xsession-errors is empty

Adding a new user also loops. Trying to delete that user after looping the login says the user is in use by /lib/systemd/systemd --user

Edit3:
I got fed up with trying to fix it and since I had already tested a clean install as working and have a separate /home I just reinstalled and will have to install all my packages again which is annoying but I got it up now. Bounty goes to the one I thought was most helpful, thanks.

5
  • Check /var/log/Xorg.0.log. According to your description I would say X crashes. I am not familiar with Debian and I don't know if you can select between wayland and Xorg, or which one you run. I would try to diagnose Xorg problems and/or graphics adapter driver. – nobody Jan 7 '20 at 8:57
  • @nobody i added the errors from the Xorg log, any ideas? – user1794469 Jan 8 '20 at 4:38
  • Also check ~/.xsession-errors in your home directory (if it's huge, first delete it using another TTY, then make a GUI login attempt and look at the results), and make sure that the filesystem containing your /home directory is not 100% full. Also, as a test, you might try creating a new user account and seeing if the problem happens with it also. If not, it's probably something specific to your session only and the ~/.xsession-errors might tell you what it is. – telcoM Jan 8 '20 at 5:21
  • Check if .xsession-errors is writable by you, for example by date >>$HOME/.xsession-errors. – Ferenc Wágner Jan 9 '20 at 20:30
  • @FerencWágner Yup, I can do that without issue. I also scanned my whole home and nothing is owned by root. (Also a new user has the same loop problem so it's probably not my home specifically.) – user1794469 Jan 10 '20 at 0:34
1
+100

There is no device /dev/dri/card0 for Direct Rendering Infrastructure, so there's only software renderer available, which might not fit the currently assigned driver in xorg.conf. Therefore, try reinstalling the drivers for X, for example (where package xserver-xorg-video-intel may vary):

sudo apt-get install --reinstall xserver-xorg-video-intel xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
0

Add your user to the 'video' group it appears to not have access to the required devices.

video: This group can be used locally to give a set of users access to a video device (like the framebuffer, the videocard or a webcam).

8
  • Ok I will edit to not require clarification. – Yevhen Stasiv Jan 10 '20 at 17:56
  • @Jesse_b "This does not provide an answer to the question" How do you know that? – mosvy Jan 10 '20 at 17:59
  • @mosvy: because as originally written it was a question and not an answer – jesse_b Jan 10 '20 at 18:01
  • @YevhenStasiv I'll check when I get home. New users have the same problem and I mesed around with the graphics drivers quite a bit so this is plausible. – user1794469 Jan 10 '20 at 18:09
  • Unfortunately, my user is a member of video – user1794469 Jan 11 '20 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.