0

I get kernel panic from my freshly compiled linux kernel booting from USB key (like here Unable to mount root fs)

 1. error      : unable to mount root fs on unknown-block(0,0)
 2. kernel version : 5.5-rc5
 3. bootloader : none (EFI stub)
 4. built-in kernel command line : root=PARTUUID=xx1-xx1-xx1-1xx
 5. root file system : f2fs
 6. kernel is moduleless

Solutions tried/tested

 1. kernel supports the filesystem on root
 2. checked PARTUUID of the root device 3 times
 3. no modules 
 4. kernel do load my sata ssd with proper PARTUUID
 5. kernel doesn't mount other USB drive
 6. BLK_DEV=y, BLK_DEV_SD=y, USB_STORAGE=y, ...
 7. tried with UUID and /dev/sda2 same result

It seems to be a USB problem something wrong in kernel configuration ?

some links already checked Unable to mount root fs, not syncing vfs unable to mount root fs on unknown-block(0 0)

0
  • Ok it turns to be a slow USB subsystem.
  • rootwait added to the kernel command line fixed that

all the credit goes to NeddySeagoon from Gentoo Forum link to the post Unable to mount root fs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.