0

I'm having some trouble applying an Oracle patch to the Management Services. After downloading and unzipping the particular patch in ORACLE_HOME, I get an error that I don't understand when trying to run an omspatcher apply command from the prerequisites:

[oracle@oracletest:/u01/oracle/software/13.2/patches/p30203518_132000_Generic/30203518/30203518]$ omspatcher apply -analyze 
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/oracle/cie/gdr/external/InventoryException : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at oracle.opatchauto.oms.OMSPatchingSession.<clinit>(OMSPatchingSession.java:85)
        at oracle.opatchauto.oms.OPatchAuto.<clinit>(OPatchAuto.java:93)
Could not find the main class: oracle/opatchauto/oms/OPatchAuto.  Program will exit.

OMSPatcher failed with error code 1

My guess is that I'm in the incorrect directory, but even then, I'm not sure where the omspatcher directory is located.

Any thoughts on how to resolve this?

Disclaimer: I'm just starting out with databases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.