4

I have installed hostapd as package for Ubuntu 12.04. Everything is configured and works great for about 10 minutes; after that, packets start to get dropped and eventually I can't even connect. Restarting the hostapd service seems to fix everything for a further 10 minutes.

I am fairly fresh to Linux. What steps I can take to further debug this behaviour?

1
  • AskUbuntu might be a better place to ask this stuff. Laptop Wireless chipsets are not commonly used on servers.
    – Magellan
    Nov 18, 2012 at 21:02

2 Answers 2

5

Try disabling WMM in your config with wmm_enabled=0. There could be a powersave feature kicking in. I had a similar issue and this solved it for me.

1

I had a similar issue. Every precisely 10 minutes hostapd used to disconnect all my clients. Using wmm_enabled=0 did not help. I changed the default parameter wpa_group_rekey=600 to wpa_group_rekey=1800 and the automatic disconnection happened only after 30 minutes.

# Time interval for rekeying GTK (broadcast/multicast encryption keys) in
# seconds. (dot11RSNAConfigGroupRekeyTime)
#wpa_group_rekey=600

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .