0

I'm using two monitors with AMD Radeon RX570 and Intel onboard graphics on CentOS 8. (My CPU is i3-8100 @ 3.60GHz.)

I have screen tearing on the 2nd monitor which is rendered by Intel onboard graphics when moving a window or watching video.

After googling, I got the information that PRIME Synchronization makes the 2nd monitor tear-free. To check it, I ran xrandr --props. The below output is extracted from it.

xrandr --props


...

HDMI-1-1 connected 1920x1200+1920+0 (normal left inverted right x axis y axis) 518mm x 324mm
    _MUTTER_PRESENTATION_OUTPUT: 0 
    EDID: 
        00ffffffffffff0038c3240200000000
        0811010380342078ea8cb5a7554d9f26
        0c5054afef8071408140818081c0a940
        b301d1c00101283c80a070b023403020
        260006442100001a243680a070381f40
        3020250030303100001a000000fd0038
        4b1f4d11000a202020202020000000fc
        0056434231303739480a2020202001ac
        020318f2450405030290230904046503
        0c001000830100008c0ad08a20e02d10
        103e9600c48e210000188c0ad08a20e0
        2d10103e9600138e2100001800000000
        00000000000000000000000000000000
        00000000000000000000000000000000
        00000000000000000000000000000000
        0000000000000000000000000000004b
    PRIME Synchronization: 0 
        supported: 0, 1
    Content Protection: Undesired 
        supported: Undesired, Desired, Enabled
    aspect ratio: Automatic 
        supported: Automatic, 4:3, 16:9
    Broadcast RGB: Automatic 
        supported: Automatic, Full, Limited 16:235
    audio: auto 
        supported: force-dvi, off, auto, on
    link-status: Good 
        supported: Good, Bad
    CONNECTOR_ID: 71 
        supported: 71
    non-desktop: 0 
        range: (0, 1)

...

To enable PRIME Synchronization, I ran xrandr --output HDMI-1-1 --set "PRIME Synchronization" 1. But, after I ran it, the 2nd monitor flicked (maybe it seems to be turned off and on quickly), and then the setting was reset to 0 again.

This situation can only be met after installing AMD linux driver for CentOS 8 v19.30, which is the recent driver at this time. If I don't install it (it means I use the default driver which is included in CentOS 8), screen tearing doesn't occur and PRIME Synchronization is 1 for the 2nd monitor. But, I should use AMD driver instead of the default driver.

How can I set PRIME Synchronization to 1? Or how can I find why it cannot be set to 1?

FYI, some information what I know are as below:

lspci -nn | grep "VGA\|Display"

00:02.0 Display controller [0380]: Intel Corporation 8th Gen Core Processor Gaussian Mixture Model [8086:3e91]
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev ef)
xrandr --listproviders

Providers: number : 2
Provider 0: id: 0xa2 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 6 outputs: 5 associated providers: 1 name:Radeon RX 570 Series @ pci:0000:01:00.0
Provider 1: id: 0x45 cap: 0x2, Sink Output crtcs: 3 outputs: 3 associated providers: 1 name:modesetting
0

I have the exact same problem with my Radeon RX590 on Gentoo Linux. I tried messing with the kernel settings, but I can't get it to enable PRIME sync. Did you ever find a solution?

I found that setting "Tearing prevention" in KDE systemsettings to "Full screen repaints", does reduce the tearing a bit. However, there is still some tearing and it is kinda annoying.

-----[EDIT]------

I was able to get PRIME sync working, with this in xorg.conf.d:

Section "Device"
  Identifier "Intel Graphics"
  Driver "modesetting"
EndSection

This seems to force using the modesetting driver on the amdgpu as well as the intel gpu, which results in working prime sync. However, this results in massive screen corruption on one of the monitors connected to the iGPU (the other one is fine). So this is not a good solution.


3
  • 1
    Welcome to the site, and thank you for your contribution. As your post doesn't completely solve the problem stated by the OP, it should possibly be a comment rather than an answer. With enough reputation,you will be able to comment on other people's posts. – AdminBee Apr 24 '20 at 9:09
  • @Andrew, thank you for your information. I've installed the new AMD driver v20.10, but still have this issue. Is this same on you? – Anselmo Park Apr 30 '20 at 9:11
  • 1
    Yes I still have this issue, I reported it on the bugtracker, and apperently PRIME Sync is simply not implemented in the AMDGPU driver: gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/-/issues/… – Andrew Ammerlaan May 1 '20 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.