After moving to a new apartment I realized it was no longer practical to use my main desktop for my projector (Optoma HD100X) in the living room (the cable run would be crazy and I'd been planning on putting together an HTPC anyway).

So, I ordered the necessary parts and put the whole thing together this friday. I went for an Asus P8H77-I motherboard and a Pentium G860 processor since that way I'd have integrated graphics and the motherboard comes with DVI, VGA, DP and HDMI outputs.

Now, at first I hooked everything up to my main workstation's secondary monitor via the DVI port everything worked just fine. Then I moved the HTPC to my living room and hooked it up to the projector via a 10 meter HDMI cable. The projector shows the usual UEFI bootup stuff just fine and the GRUB boot menu shows up. Then once past that the projector stops receiving a signal.

After a little testing I concluded that if I run the cable to my main desktop (iMac 27") and use a DP-to-HDMI adapter it works just fine. I also discovered that if I hook up my secondary monitor (also 1920x1080) to the HTPC at the same time as the projector is hooked up to it then I get an image on both the monitor and the projector.

So in short:

  • Main desktop + HDMI to projector => HDMI output to projector works
  • HTPC + DVI to monitor => DVI output to monitor works
  • HTPC + HDMI to projector => No HDMI output to projector
  • HTPC + HDMI to projector + DVI to monitor => 1080p output to both monitor and projector (but trying to extend the desktop rather than just clone it results in both the monitor and the projector going blank)

Now, I don't have a long enough DVI cable to test the projector with a DVI connection to the HTPC but I have a nagging suspicion that it would work just fine (projector is ceiling mounted so I'm not in any hurry to get it down just to test this).

Does anyone have any experiences with a problem like this? For now I've left my secondary monitor sitting next to the HTPC so I can use the HTPC but I'd rather move it back to my main desktop). To me this seems like something I should be able to deal with in software.

Right now the HTPC is running Debian (wheezy as the version of ALSA in squeeze didn't recognize the integrated sound card) although I've also tried Ubuntu and Fedora, Fedora had the exact same issue and with Ubuntu the Live image installer worked but it refused to give any video output at all (DVI or HDMI) after installing and rebooting.

I should probably also note that running Xorg -configure (with X and gdm off, of course) results in an error that reads Number of created screens does not match number of detected devices and then it dumps out an Xorg file which looks a bit quirky, including that it is set to use the vesa driver.

Edit: I just noticed that if I start the HTPC with the monitor connected but not turned on then both the projector and the monitor wind up reporting "No signal". I'm starting to think that there's some kind of handshake issue here...

Edit 2 (2012-11-22): Posted an answer myself earlier thinking my problem was solved but now I'm having the same issue with the new HDMI cable. After a couple of reboots I stopped being able to get a video signal from the computer to the projector. I did however notice a pattern:

If video output worked during initial stages of boot (UEFI, grub, Linux until X starts) then on the boot it will not work at all, not even for the EUFI splash screen.

On those bootups where I get the UEFI splash screen I also get grub and debian booting right up to the point where it's about to switch to 1920x1080, then the projector just reports "no signal".

So at this point I'd be happy with a way to force X to always drive the HDMI port @ 1920x1080 just to get this running reliably.


Well, I finally got things working. Sort of.

What was required was a BIOS update to stop the weird "no signal" issues that would happen every other boot (I noticed the BIOS version the motherboard shipped with was fairly recent but not a version available from Asus' website which made me a bit suspicious of it and it appears my suspicions were correct).

I also had to reconfigure grub to wait 10 seconds before automatically booting as otherwise the projector simply couldn't keep up (even with grub configured to run at 1920x1080 the initial stages of booting happen at a lower resolution and apparently several quick resolution changes confuse the projector).

Still having some issues with resolution switching though (the signal just goes away completely if I attempt to switch resolutions to say, 1280x720, after booting and logging in).

Well, at least with a new HDMI cable and a BIOS update things finally work (of course, with the new BIOS version I can no longer force the machine to use my 1600 MHz RAM @ 1600 MHz since it absolutely refuses to let me "overclock" it above 1333 MHz).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.