0

Here is what I get when I execute 'picom':

[ 03/01/20 15:24:08.887 parse_config_libconfig WARN ] Option `no-dock-shadow` is deprecated, and will be removed. Please use the wintype option `shadow` of `dock` instead.
    [ 03/01/20 15:24:08.887 parse_config_libconfig WARN ] vsync option will take a boolean from now on. "none" is interpreted as "false" for compatibility, but this will stop working soon
    [ 03/01/20 15:24:08.887 parse_config_libconfig WARN ] glx-swap-method has been deprecated since v6, your setting "undefined" should be removed.
    [ 03/01/20 15:24:08.887 parse_config_libconfig WARN ] "clear-shadow" is removed as an option, and is always enabled now. Consider removing it from your config file
    [ 03/01/20 15:24:08.887 parse_config_libconfig WARN ] "paint-on-overlay" has been removed as an option, and is enabled whenever possible

And 'compton':

[ 03/01/20 15:42:33.943 parse_config_libconfig WARN ] Option `no-dock-shadow` is deprecated, and will be removed. Please use the wintype option `shadow` of `dock` instead.
[ 03/01/20 15:42:33.944 parse_config_libconfig WARN ] vsync option will take a boolean from now on. "none" is interpreted as "false" for compatibility, but this will stop working soon
[ 03/01/20 15:42:33.944 parse_config_libconfig WARN ] glx-swap-method has been deprecated since v6, your setting "undefined" should be removed.
[ 03/01/20 15:42:33.944 parse_config_libconfig WARN ] "clear-shadow" is removed as an option, and is always enabled now. Consider removing it from your config file
[ 03/01/20 15:42:33.944 parse_config_libconfig WARN ] "paint-on-overlay" has been removed as an option, and is enabled whenever possible
[ 03/01/20 15:42:33.944 session_init WARN ] This compositor has been renamed to "picom", the "compton" binary will not be installed in the future.

This command to check what composite manager is running shows no output:

inxi -Gxx | grep compositor

I also have this line in my i3 config file:

# picom
exec_always --no-startup-id picom --config ~/.config/picom/picom.conf

I'm not sure what they are asking me to do here as the compton command mentions that 'compton' has no been renamed to 'picom', so I thought I would just have to change the .conf file name etc. but this did not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.