I am a software developer by trade. I know little about linux and general networking but I do use docker a lot.

About a month ago I dual booted. I now have Manjaro Linux and Windows 10.

I am working on a pet-project. I have the following Dockerfile. On my Manjaro Linux when I run docker build . --no-cache the dockerfile fails to build. The error I get is this:

dockerfile build fail on linux

When I run the same command on Windows, the dockerfile builds without any problems. Also, someone else running Manjaro linux ran the same command, and for them it built fine too, even on Linux.

This means the issue it local to my machine, something is not right in my Manjaro install. The install is fresh about a month old so I'm not sure what can be wrong.

I ran sudo iptables -nL to see what I have, here is the output:


I read the official docker documentation on iptables, and it tells users not to mess with the docker chains.

I'm now stuck and I'm not sure why my dockerfile is failing.

1 Answer 1


This error is covered in their forums here: https://discourse.elm-lang.org/t/cannot-install-any-elm-packages/3084

Copying answers for archival:


At the end of the error message it says the URL doesn’t exist. So this looks like a networking issue. Maybe test if you can reach the same URL from the same box using curl or wget or a browser. Maybe it’s behind a firewall or you need to set HTTPS_PROXY in the environment?


https://package.elm-lang.org is not set up for ipv6 (I just tested). So you need to change the protocol to v4.


  1. ping package.elm-lang.org
  2. Adds the ip into /etc/hosts

The first thing I recommend trying is disabling IPv6 in Manjaro (if you have it enabled).

  • I disabled IPv6 and still got the same problem.
    – J86
    Jan 4, 2020 at 21:54
  • @J86 Can you run curl on that URL and see if it is successful?
    – Matt S
    Jan 7, 2020 at 13:48
  • I just did. The curl was a success, but it still failed on the build step. Here's the output.
    – J86
    Jan 8, 2020 at 12:09
  • Can you check that systemd-resolved is symlinked to resolv.conf? This should force everything to use the the systemd DNS stub file. Running the following should take care of this: # ln -sf /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf Reference: wiki.archlinux.org/index.php/Systemd-resolved#DNS
    – Matt S
    Jan 8, 2020 at 17:09
  • How do I check that it is linked? I tried doing file /usr/lib/systemd/systemd-resolved and it tells me that the file is dynamically linked, but it doesn't tell me where it is linked to. Also that reference you linked to says I ought to have /run/systemd/resolve/stub-resolv.conf but I don't! See here.
    – J86
    Jan 8, 2020 at 18:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .