0

I installed Squid and snmp on my CentOS 7 virtual machine and now I would like to monitor the proxy server using snmp. The problem is that I cannot retrieve (by the snmpwalk command) any of the available Squid OID under the 1.3.6.1.4.1.3495 parent tree. See this link for the entire collection: Squid Wiki

For instance, if I prompt the command:

snmpwalk -v 1 -c public <machine_ip>:3401 .1.3.5.1.4.1.3495.1.1.2.0

which is supposed to retrieve the cacheSysStorage, I get a "NO Response" error. I even tried the following alternative prompts:

snmpwalk -v 1 -c public <machine_ip> OID_number

snmpwalk -v 1 -c public localhost:3401 OID_number

So with or without the 3401 port, it does not matter: it always results with a timeout error. Looking at the snmpd.conf file, I saw that another OID tree is getting some system information, so I prompted the following:

snmpwalk -v 1 -c public <machine_ip> .1.3.6.1.4.1.2021.100

I get a positive response! But it is not the OID tree needed for monitoring the Squid proxy server.

FYI, I edited the snmpd.conf file with the following:

proxy -v 1 -c public <machine_ip>:3401 .1.3.6.1.4.1.3495.1

and I double checked that the public zone in FirewallD service has the port UDP 3401 allowed. I think to have tried any possible action but I am still unable to test OID information retrievement.

Could you suggest me anything to check or modify? Thank you.

1 Answer 1

1

Ok, it looks like an incorrect configuration setting of the squid.conf file. For anyone in the future would come here...

I setup the access control properties by using Webmin (Servers > Squid proxy server > Proxy restrictions): I had allowed the snmp_community called public (which is the one I use) but this created a http_access allow rule in the configuration file instead a snmp_access, as written here: http://etutorials.org/Server+Administration/Squid.+The+definitive+guide/Chapter+14.+Monitoring+Squid/14.3+Using+SNMP/

Now I am getting the information correctly. Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.