1

Even with the realtime kernel, following the steps here: https://jackaudio.org/faq/linux_rt_config.html and setting jack to realtime (QJackCtl -> Settings -> Parameters -> Realtime, or using the jackd -R command line arg), I was getting a ton of XRUNs (visible in QJackCtl as the red number, or in the Messages dialog), making the sound stutter a lot.

Increasing the Frames/Period and Periods/Buffer made the XRUNs go away, but increased the latency to a few hundred ms.

It works on a different computer with a similar manjaro installation, so I guess it might be somewhat related to the hardware. The mainboard is a "MSI B450M Mortar Max", it's an AMD system. aplay --list-devices says Realtek ALC892, lspci -v | grep -i audio says "Starship/Matisse HD Audio Controller".

1

1 Answer 1

2

It works when I increase the Sample Rate. I have it at 88200 set now and it works really good without XRUNs and stuttering.

You can do that in QJackCtl in Setup... -> Settings -> Parameters

1
  • When I use raw ALSA, I get playback and recording under 20ms without stuttering at 48KHZ. I tested with ZynAddSubFX for playback and Ardour for recording/playback. Unfortunately, if I even start the Jack 0.9.1 audio server on Debian 11 at a variety of sample rate, frame and period settings I always get tons of periodic xruns. The funny thing is I used Jack for WIndows on WIn 10 a few nights ago, and while it was a little unstable, I seemed to get very few xruns and those I did get seemed to be at random times...
    – Shawn Eary
    Commented Mar 5, 2022 at 3:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .