1

I have two computers and they have pretty similar manjaro installations. Both have the same jack2, QJackCtl and kernel versions installed.


Computer 1

This is the one that works:

I can start jack and hear stuff in lmms and Hydrogen. Other audio output from pulseaudio will then stop which is expected afaik. When stopping and starting jack in QJackCtl on this one, it looks like this:

01:01:48.817 Client deactivated.
01:01:48.827 JACK is stopping...
Jack main caught signal 15
Released audio card Audio0
audio_reservation_finish
01:01:49.074 JACK was stopped
01:01:51.610 JACK is starting...
01:01:51.611 /usr/bin/jackd -dalsa -dhw:0 -r48000 -p1024 -n2
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
01:01:51.652 JACK was started with PID=1969.
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
jackdmp 1.9.14
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2019 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
Cannot lock down 82280346 byte memory area (Cannot allocate memory)
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
Cannot use real-time scheduling (RR/10) (1: Operation not permitted)
AcquireSelfRealTime error
01:01:53.832 JACK connection change.
01:01:53.834 Server configuration saved to "/home/mango/.jackdrc".
01:01:53.835 Statistics reset.
01:01:53.866 Client activated.
01:01:53.867 Patchbay deactivated.
01:01:53.882 JACK connection graph change.
Cannot lock down 82280346 byte memory area (Cannot allocate memory)

Computer 2

On this one, all pulseaudio apps will keep playing sound, lmms and Hydrogen won't. When stopping and starting jack in QJackCtl, this is all I see:

00:52:35.422 Client deactivated.
00:52:36.599 JACK connection change.
00:52:36.618 Client activated.
00:52:36.619 Patchbay deactivated.
Cannot lock down 82280346 byte memory area (Cannot allocate memory)

As you can see, it's not logging much stuff.

Inserting the /usr/bin/jackd -dalsa -dhw:0 -r48000 -p1024 -n2 command from the working machine here yields:

`default' server already active
Failed to open server

If I run the same command directly after a reboot or after using jack_control stop, it yields:

audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
Released audio card Audio0
audio_reservation_finish
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server

Same for jackd -d alsa

the PCM error message does not appear on computer 1.


On both machines, QJackCtl claims Jack to be "Active"

Where could I continue to look for the problem?

Thanks

8
  • jackd -d alsa -d hw:1 makes sound play in lmms, but it sounds super glitchy and stuttering. pulseaudio is stopped when I run this.
    – sezanzeb
    Commented Dec 30, 2019 at 10:15
  • in QJackCtl Setup... -> Settings -> Output Device setting this to ...(hw:1) does the same thing as using -d alsa -d hw:1. Audio still stuttering. The list of devices, and especially the numbering, corresponds to the output of aplay -l ("card 0", "card 1")
    – sezanzeb
    Commented Dec 30, 2019 at 10:28
  • installing realtime-privileges and adding myself to the realtime group didn't change it.
    – sezanzeb
    Commented Dec 30, 2019 at 10:39
  • Increasing the number of Periods/Buffer and Frames/period in QJackCtl makes the stutter go away (which apparently are XRUNs), but increases the latency so much that this is not a solution
    – sezanzeb
    Commented Dec 30, 2019 at 10:47
  • ticking Realtime in QjackCtl and using a realtime kernel did not make the XRUNs go away
    – sezanzeb
    Commented Dec 30, 2019 at 10:52

1 Answer 1

2

The solution for no audio playing at all was to check the output devices in QJackCtl

Setup... -> Settings -> Advanced -> Output Device

and setting it to my soundcard.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .