2

I am Using Ubuntu 18.04 and Higher Versions.

The gnome-lock screen/ gnome-screensaver what ever it is called,

There are two possibilities of locking the screen in my use case:

  1. Lock the screen with Super+L default shortcut.
  2. When the session idle-delay reaches. [gsettings set org.gnome.desktop.session idle-delay <'x' seconds>]

In the 1st case - the lock screen appears first and then system goes to black screen/dimming what ever it is called.

There is a workaround for this case: How do I prevent the blank screensaver when using keyboard shortcut to lock the computer?

For the 2nd case - the system starts fading to black and then screen gets locked (which is only seen when we move the mouse or hit any key that the screen is locked.)

Question: how can we programmatically completely remove this screen dimming/fading in both the cases.

Target: when screen gets locked either manually or automatically, just show the lockscreen.

1 Answer 1

0

On Ubuntu, since 11.10, the screensaver tool installed by default is the Gnome screensaver and the parameters available to it are as follow:

$ gsettings list-recursively | grep screensaver
org.gnome.desktop.screensaver picture-opacity 100
org.gnome.desktop.screensaver logout-enabled false
org.gnome.desktop.screensaver lock-enabled false
org.gnome.desktop.screensaver logout-delay uint32 7200
org.gnome.desktop.screensaver embedded-keyboard-enabled false
org.gnome.desktop.screensaver primary-color '#023c88'
org.gnome.desktop.screensaver idle-activation-enabled true
org.gnome.desktop.screensaver secondary-color '#5789ca'
org.gnome.desktop.screensaver logout-command ''
org.gnome.desktop.screensaver color-shading-type 'solid'
org.gnome.desktop.screensaver embedded-keyboard-command ''
org.gnome.desktop.screensaver show-notifications false
org.gnome.desktop.screensaver picture-options 'zoom'
org.gnome.desktop.screensaver lock-delay uint32 0
org.gnome.desktop.screensaver show-full-name-in-top-bar true
org.gnome.desktop.screensaver picture-uri 'file:///usr/share/backgrounds/warty-final-ubuntu.png'
org.gnome.desktop.screensaver status-message-enabled true
org.gnome.desktop.screensaver ubuntu-lock-on-suspend true

The only way to fix this would be to install a different screensaver. I personally would not recommend you do such. You could even program your own. If you just want a black screen, that's easy. To also make sure the screen goes to sleep, that's a bit more involved but you can find existing open source code to do it.

Btw, what you are trying to do is remove what in Gnome is called Animations. Unfortunate, but at some point it became pretty much impossible to not get all of those animations (like when I swap between screen, it scrolls, I'd like to just go there at once...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.