4

I am using fbpanel in openbox. I have 3 monitors: One in the middle, and two on each side.

Currently fbpanel is spread along all 3 monitors.

Can I configure fbpanel to only appear on one monitor (monitor 1) ?

3
+500

It's not possible to put fbpanel on only one monitor by default but it's possible to do that using -x option that is added by this patch. After applying this it you can use -x <MONITOR_NUMBER to display fbpanel on a given monitor, for example:

$ ./panel/fbpanel -x 1

I tried and it works on my Slackware 14.2 with Fluxbox.

As correctly noted by OP in the comments below this patch cannot be cleanly applied onto current stable version of fbpanel because implementation of menu_pos() function changed. Instead of looking for the differences I replaced current implementation of menu_pos() with the implementation from the patch I linked above. To try it:

$ git clone https://github.com/ardrabczyk/fbpanel
$ cd fbpanel
$ git checkout xinerama-support

Then build and optionally install normally.

To apply patches to the Debian package build system:

$ cd debian/patches
$ wget http://drabczyk.org/xinerama-support.patch
$ echo xinerama-support.patch >> series
$ cd -
$ dpkg-buildpackage

I got:

gpg: skipped "Ulises Vitulli <dererk@debian.org>": No secret key
gpg: dpkg-sign.WfacYo70/fbpanel_7.0-3.dsc: clear-sign failed: No secret key

dpkg-buildpackage: error: failed to sign .dsc file

but apart from that building succeeds. Install package:

sudo dpkg -i ../fbpanel_7.0-3_amd64.deb

(I guess that amd64 might be different on non x86-64 machines).

9
  • which version of fbpanel did you patch ? I am on Debian Buster, and the fbanel version I am trying to patch is 7.0. I get: panel/misc.c: Hunk # FAILED at 713. – Martin Vegter Jan 4 '20 at 4:43
  • I patched 6.1 from downloads.sourceforge.net/fbpanel/fbpanel-6.1.tbz2 – Arkadiusz Drabczyk Jan 4 '20 at 12:30
  • @MartinVegter: see update – Arkadiusz Drabczyk Jan 4 '20 at 23:51
  • I need a Debian package that I can install. Can I use your patch, and apply it to the Debian package I am trying to compile ? I am using the standard Debian way to compile a package: apt-get source fbpanel and then dpkg-buildpackage. – Martin Vegter Jan 6 '20 at 19:01
  • @MartinVegter: see updated answer – Arkadiusz Drabczyk Jan 6 '20 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.