I tried to update my "Fedora" by using Terminal. It worked great at first but after a while it said that "there is not enough space in var/". I added some more space by using Gparted and now everything is OK. My question is, How can I clean all useless downloaded files or junk files in var/?
Thank you for your help.

The tail of error was this
" installing package fedora-chromium-config-1.1-3.fc31.noarch needs 81MB on the /var filesystem

Error Summary

**Disk Requirements: At least 81MB more space needed on the /var filesystem."

These are in var/

account crash ftp lib log nis run www adm db games local lost+found opt spool yp cache empty kerberos lock mail preserve tmp

These are in cache/

abrt-di cups foomatic gdm ibus ldconfig libX11 PackageKit realmd app-info dnf fwupd httpd krb5rcache libvirt man private

  • Have a look in /var/tmp and /var/spool ?
    – steve
    Dec 28 '19 at 14:03
  • 1
    @steve Dear Steve. Thank you for your reply. I used DU command to know how much space they were using and I got that tmp/ was using just 198 Mb and it was 52 Kb for spool/. Also, It was 412 Mb for cache/. All access denied files are missed in total! Thank you.
    – ismaeel
    Dec 28 '19 at 23:17

I've just used du -h | sort command to know which directory get more space and I found that /cache/PackageKit/31 is in charge. Using StackExchange, I find that I can remove all files in this directory with sudo pkcon refresh force -c -1 but I've not dare to do this! Besides I have enough space on my hard-driver. Thank you for your helps. What I found

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.