1

I have a live-boot USB with Linux Mint 19.1 Cinnamon, I placed the boot image with Rufus and it has worked without problems on other machines.

Now I have built a PC with various parts I've found on my shelf.

Specs:

  • Motherboard: Gigabyte GA-970A-DS3P Rev 1.0 (BIOS Version F1)
  • RAM: Kingston HyperX 8G (4G+4G kit)
  • CPU: AMD AM3+ FX-6300 Six-core processor
  • GPU: MSI GTX 1060 Gaming X 6G
  • PSU: Corsair VS550 80 Plus White
  • Storage: Kingston A400 120G SSD

When I try to use the Live-USB, I can get to the Grub menu where I select whether to launch Mint normally or in compatibility mode.

I tried both ways, but the Linux Mint logo just stays there loading, and when i press arrows or escape to show the background loading messages, it shows following parts:

Failed to mount '/dev/sda': Operation not permitted

and

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda': Operation not permitted
The NTFS partition is in an unsafe state.
Please resume and shutdown Windows fully (no hibernation or fast restarting),
or mount the volume read-only with the 'ro' mount option

and

/init line 7 can't open /dev/sdb no medium found

Since sda is mentioned alongside the Windows-related message, I believe it is the Kingston SSD and the sdb is the USB-stick.


The Kingston SSD does not contain Windows installation, but I used it as a secondary SSD in my Windows laptop as an installation drive for games. I did format it before removing it from the laptop.

I removed the SSD and tried to boot again (with no other storage media attached, just the USB itself), then it gave me just this message:

/init line 7 can't open /dev/sda no medium found

Here sda must be the USB-stick since the SSD is now removed.

I tried different USB-stick with different distro (Zorin OS), but it did not work, the same error message still appeared.

There is no "Secure-boot" option in BIOS and I made sure that the 1st boot order device is the USB-stick.


Any ideas why this happens?

Since removing SSD and switching USB-sticks did not help, it's not the storage media. And CPU/GPU wouldn't/shouldn't affect in this case anyway.

That leaves Motherboard BIOS and RAM, but the RAM sticks are quite new still (I'll run memtest86 just in case). But I am running out of ideas where to look after these mentioned efforts.


UPDATE: I wiped the SSD with Windows Diskpart utility (CLEAN ALL -command, total wipe, all sectors zero), now I don't get the NTFS-related error, but I still cannot boot to Mint or other distros.

I took pictures of the messages: enter image description here

And: enter image description here

dev sr0 is the CD/DVD-drive, but I don't even have one connected, so that message shouldn't be the reason. CD/DVD-drive is not mandatory for booting.

I can't make any sense of the rest of the messages.


UPDATE: I may have found potential solution.

I managed to boot to desktop after switching the USB-stick from USB3.0 to USB2.0, for some reason USB3.0 is not recognized at boot.

Then I had new problem when mouse and keyboard did not respond after reaching the desktop.

Turns out that some specific Gigabyte-motherboards need to have IOMMU (Input–output memory management unit) enabled, after enabling the IOMMU, the mouse and keyboard worked fine.

So far this issue seems to be solved. I'll try to actually install a distro and boot to it and update the situation again after that.


UPDATE: OK, I managed to install Pop!_OS 19.10 to the PC now, though it first did not want to do it (somehow Rufus does not flash the image properly, had to use Etcher).

SUMMARY:

  • NTFS-problem => just wipe the disk
  • medium not found => change from USB3.0 to USB2.0
  • Mouse/Keyboard not responding after boot => enable IOMMU (might be Gigabyte-specific solution)
1

OK, I managed to install Pop!_OS 19.10 to the PC now, though it first did not want to do it (somehow Rufus does not flash the image properly, had to use Etcher).

SUMMARY:

  • NTFS-problem => just wipe the disk
  • Medium not found => change from USB3.0 to USB2.0
  • Mouse/Keyboard not responding after boot => enable IOMMU (might be Gigabyte-specific solution)
  • Install failing => flash the USB with different tool (from Rufus to Etcher)
0

It sounds like there is a broken NTFS filesystem, or partition table on the SSD, which is causing the message about the unclean filesystem. You could try making a new partition table on the disk, and then making new partitions. The archwiki article on partitioning has a good intro to partition table types, disk partitioning and suggests some linux tools for modifying partition tables and partitions.

If you only have access to a Windows computer you could try to initialize the disk as described in the Microsoft docs here. I've never tried to do this on Windows though so I'm not sure if that's what you want.

I would guess that when you take out the SSD and try to boot from the liveboot USB key the error you see is due to the liveboot key looking for a potential installation candidate. I'm not sure if this is expected behaviour for the Mint liveboot key, but if you've got another HDD sitting around you could try plugging that in and then booting from the liveboot key to see if that works.

1
  • Wiped the disk, now no more NTFS-errors, but I still cannot boot. Root of problem lies somewhere else.
    – K4R1
    Dec 28 '19 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.