0

I have just installed FreeBSD 12.1 and want to give it a try. I used qemu. When I types pkg, it started normal bootstrapping. After downloading, it says No trusted fingerprint found matching package's certificate. I am confused because there isn't any error during the installation process. Any ideas? If needed, I will post the log.

At the time of 2020/01/04 10:19:45, I reopened this question.

Now I have seen this question and this. None of them can help me. I tried by building pkg in port: /usr/ports/ports-mgmt/pkg, but it couldn't build. Gives error: <jemalloc>: jemalloc_arena.c:647: Failed assertion: "nstime_compare(&decay->epoch, &time) <= 0

  • See unix.stackexchange.com/q/430038/5132 for an example of how to better write a question like this. – JdeBP Dec 27 '19 at 17:05
  • Use -f option , pkg bootstrap -f , pkg update -f... – GAD3R Dec 28 '19 at 12:12
  • 1
    @GAD3R well I tried but no, it doesn't work. --fixed typo – Chrimpyslime Jan 4 at 14:25
  • Hello. I still can't resolve this issue. I tried to build the applications I need from ports, but all the ports is depended on ports-mgmt/pkg which fails to build. Which means, I can't install, or even get any sources/binaries. Do you recommend me to report this problem on FreeBSD forum / their support? Please reply. – Chrimpyslime Feb 19 at 1:49
0

Solved by myself! Changed one line of /etc/pkg/FreeBSD.conf to follow: fingerprint: "/dev/null" and it went great!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.