1

I have no idea what I did but when I startup I get this message in BusyBox:

Give up waiting for root file system device. Common problems:
 -Boot args (cat /proc/cmdlines)
  -Check rootdelay= (did the system wait long enough?)
 -Missing modules (cat /proc/modules; ls /dev)
ALERT! UUID=eb253f2f-5fbd-4952-810a-2841b01e3425 does not exist. Dropping to a shell!

blkid returns this:

/dev/sda1: LABEL="ESP" UUID="9C01-5EBA" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="74264bc4-8b04-48bc-8fc7-406f87a01438"
/dev/sda3: LABEL="Acer" UUID="826E03A86E0393D7" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d770662a-4898-40e9-ba97-0d576451a126"
/dev/sda4: LABEL="Recovery" UUID="5624055124053611" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a4611369-500b-4582-8af6-7a50a221f972"
/dev/sda5: UUID="eb253f2f-5fbd-4952-810a-2841b01e3425" TYPE="ext4" PARTUUID="30a44434-207e-44f6-a85e-ff516aed39b2"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/loop5: TYPE="squashfs"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="073584e1-fef1-420b-92b8-25bebfc7e809"

So it should work and it actually does when I start the system from the "recovery mode" in Grub. I just have to press CTRL+D at some point. But When I start the computer as I always did it goes straight to BusyBox. I have no idea what to do as I went through a number of forums already.

[EDIT SOLVED] I had edited /etc/default/grub and added lines that broke down my startup. Removed them, back to normal. Lesson learned, don't change things you don't know, keep track of the things you change...

1
  • Hello, not really no...I have been trying to fix another issue I had with Debian not being able to reboot or shutdown. But at least the computer started up until yesterday... Dec 27 '19 at 14:53
4

So, when the boot process attempts to mount the root filesystem, UUID=eb253f2f-5fbd-4952-810a-2841b01e3425 cannot be found, but once you get dropped to a shell and enter the blkid command, it actually can be found. Right?

Then, it looks like you've managed to make the system boot process so fast that the system is attempting to mount the root filesystem before /dev/sda is properly detected and ready for use. (Perhaps "a good problem to have"?)

As suggested in the message, you might try adding a boot option rootdelay=5 to delay mounting the root filesystem for 5 seconds to allow the hardware detection to complete first. If that allows the system to boot without problems, try with smaller rootdelay values until you find the smallest value that allows the system to boot reliably.

You might also check the health status of your disk with e.g. smartctl -H -i -A -f brief -l xerror,error -l devstat -l sataphy /dev/sda. First, pay attention to this part:

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

If it says something other than PASSED, your disk is either on its last legs or already failing, which might explain why the disk may have become slower to start up. The SMART attribute listing and possibly hardware error logs (if supported by your disk model) may give more detailed information about the health of your disk.

1
  • Smarctl returned a PASSED result. Where am I supposed to add the delay option? I don't want to ruin things more than they already are. And yes, when I boot with the "recovery mode" from GRUB I have no problem at all, just have to press CTRL + D. And then I can use blkid which finds the root filesystem. Dec 27 '19 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.