0

I have a linux server (in Nutanix) where normal user cannot resolve hostname through proxy but root can, below is the result:

backup user:

[backup@~]$ curl --insecure --url "https://outlook.office365.com:993/"
curl: (6) Couldn't resolve host 'outlook.office365.com'

root user:

[root@ ~]# curl --insecure --url "https://outlook.office365.com:993/"
* OK The Microsoft Exchange IMAP4 service is ready. 

Below is my proxy setting ( all user can read this file):

[root@ ~]# env | grep -i proxy
http_proxy=http://10.xxx.xxx.xxx:8080/

I have checked backup user can read /etc/resolv.conf and /etc/nsswitch.conf.

What should I check further?

  • What adds the proxy setting to root's env? Is it identical for the backup user? If not, it needs to be made for the backup user. – hopnet Dec 27 '19 at 3:42
  • Hi, yes, is the same setting for backup user, this is root env setting:[backup@ ~]$ cat /etc/environment http_proxy="10.xxx.xxx.xxx:8080" – Caron Dec 27 '19 at 5:07
  • Please add to your question the result of the ordinary (backup) user running env | grep -i proxy – roaima Dec 27 '19 at 9:45
  • Is the server running on SELinux? Run $ getenforce lets see – James John Dec 27 '19 at 10:56
0

Double check this command env | grep -i proxy into the user affected. Remember to add https_proxy, http_proxy, ftp_proxy and sftp_proxy. Try to logging in to the user and set them manually. If works, the problem related to the procedure for load the proxy.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.