0

I've just installed last kubuntu and zsh shell, not for first time by the way. But in this time it shows some configuration option (perhaps it occurs problem), I chose something and quit. Then as usually i've change zshrc file and zhystory with my old, but .zshrc won't work. An error occures in first possible line (in this case it is a comment, but i've change it and error in first character too):

➜  ~  zsh
/home/akder/.zshrc:1: command not found: #

So it load nothing. I install it with sudo apt-get install zsh, there is no error. I've tried to reinstall it, but has the same result.

zsh --version
zsh 5.0.0 (x86_64-unknown-linux-gnu)
2
1

It looks like you're setting histchars (or HISTCHARS) in some other zsh configuration file that is read before ~/.zshrc: /etc/zsh/zshenv, ~/.zshenv or /etc/zsh/zshrc. Fix: don't do that.

3
  • I checked all files in /etc/zsh/ zshenv, zprofile, zshrc, zlogin and all that files in home there is no HISTCHARS. But now I see that .zprofile works and i can use it instead .zshrc
    – zishe
    Nov 17 '12 at 4:47
  • It works but now it dont, even in /etc/zsh/.zshrc file
    – zishe
    Nov 17 '12 at 6:03
  • I reinstalled it, removed '/etc/zsh/', thin in install menu check 0 (it was all about creating zshrc file) change i with my content and now it works, i mean the error is still there, but all other functions like autocomp works file.
    – zishe
    Nov 17 '12 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.