3

I am not able to install Terminator in Rhel 8. I do not want to install it using "snap".

The process that used to work in Rhel 7 does not work in Rhel8.

2
  • Hello @jvacaq. The Terminator package in CentOS/RHEL 7 was provided by EPEL repository as we can see in this URL http://mirrors.up.pt/fedora-epel/7/x86_64/Packages/t/. However, the EPEL repository for CentOS/RHEL 8 doesn't provide it, as you can see it here: http://mirrors.up.pt/fedora-epel/8/Everything/x86_64/Packages/t/. The last released version 1.91 is quiet old (2017) and is available at launchpad.net/terminator/gtk3/1.91 . You can try to install it using the source code.
    – Nuno Dio
    Commented Dec 27, 2019 at 0:19
  • Hi, yes I compiled from source, but now I get this error message: You need to install the python bindings for gobject, gtk and pango to run Terminator.
    – jvacaq
    Commented Dec 27, 2019 at 20:21

2 Answers 2

5

As I already mentioned in the comment, at this moment the terminator package is not available in the EPEL8 repository. However, for what I can see in this ticket request, there are some effort to add the last version of terminator to EPEL8 repository.

In the comments we can see that mattrose worked on a python3 terminator version. I did a few tests of his version and it ran without any apparent issues.

To install it you just need to use his repository:

$ sudo dnf copr enable mattrose/python3-terminator
$ sudo dnf repolist
$ sudo dnf install terminator

Of course, this is not a supported/official release, so, is up to you to decide if you want to use it or not.

I hope that helps.

2

This issue seems to have been resolved. Now, on CentOS 8 (rhel 8) you can simply execute:

sudo dnf install epel-release -y
sudo dnf install terminator -y
2
  • This worked perfect for me on rhel 8.4. Thank you.
    – Bon Ryu
    Commented Oct 18, 2021 at 1:57
  • This worked on CentOS 7 Commented Feb 8, 2023 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .