0

I recently resized my Manjaro partition through gparted to make some space for a swap partition, but after running update-grub, my GRUB no longer shows an entry for Windows 10 on my system.

I've searched through nearly every other question on this website concerning this issue, but none of the solutions seem to have helped. Things I've tried:

  • Booting into Windows and running bcdedit commands (can't do that since I can't boot into Windows)
  • Mounting the Windows partition and then running os-prober
  • Booting off an elementaryOS live cd and running boot-repair, the output of which can be found here: http://paste.ubuntu.com/p/FwvhtsCZk5/
  • Booting off a Windows rescue disk and running chkdsk on the drive, then running Startup Repair
  • Creating the following custom GRUB entry in /etc/grub.d/40_custom (shows in GRUB menu, but booting to it shows "There is no operating system on this disk."):
menuentry "Windows 10" {
    insmod ntfs
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 1A5E78DA5E78B05D
    chainloader +1
}

Nothing seems to have helped. Is there any other thing I'm missing that I can do to get Windows 10 back on the menu?

As far as I know, my system boots with BIOS, not UEFI.

  • Windows in BIOS mode typically has a small 100MB boot partition with bootmgr & BCD. You do not have that nor have those essential boot files in your main Windows partition. You do not have to create new boot partition but have to add boot flag to sda2 and run Windows full set of repairs to restore bootmgr & BCD. Or restore from your backup. – oldfred Dec 26 '19 at 4:44
0

Thanks to a helpful comment pointing me in the right direction, I realized I was missing the Windows boot partition on my system and thus there was nothing for os-prober to find.

It turns out, when I restored my system backup earlier onto sdb, I forgot to also restore the boot partition. The fix was as simple as restoring the backup once again (making sure to restore the 100MB boot partition as well) and rerunning update-grub. Just like that, Windows 10 (on /dev/sdb) shows up in GRUB again.

Thanks for the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.