0

I am having a brand new RPI4B and I am booting from a 128Gb SD card. My RPI is connected by a network cable directly to my WiFi router and I have configured static IP address in the dhcpd.conf file. The problem is that every time I issue sudo reboot command the RPI doesn't go up. I can recover it by re-plugging the network cable or by disconnecting the power for a couple of seconds. My issue looks to be very similar to this issue described on Github: link which despite being closed doesn't seem to be resolved.

I have tried the following steps:

sudo apt update 
sudo apt upgrade 
sudo apt dist-upgrade
sudo apt autoremove
sudo apt full-upgrade 
sudo rpi-update

If I switch to DHCP by commenting out the static IP address lines, I am still unable to connect to my Raspberry Pi after system reboot. Unfortunately, whatever I try I can't get my RPI to get back online after command-line reboot.

  • Perhaps there is something in the logs that might shed some light on this? – schaiba Dec 25 '19 at 8:13
  • that was the problem there was nothing unusual in the logs. Everything looks perfectly normal. – Georgе Stoyanov Dec 25 '19 at 10:25
0

Apparently, the problem was in the power supply I was using, which was coming with my phone and not an original one. Even though it was 5V, 4A every time I was issuing sudo reboot command it was simply shutting down the board and I needed to either re-plug the LAN cable or re-inserting the power supply.

I have exchanged the power supply with 5V, 2A from another phone and now it works perfectly fine and I was able to remotely and directly reboot the board without a hitch.

I guess this is coming from the implementation of the USB-C which is way more complex standard compared to micro USB.

  • fwiw, that has nothing to do with USB-C; your 5V, 4A PS is probably a fake and would fail even if connected directly to the pins 2-6 or 4-6; IMLE rp4 is very fastidious and is not easily fooled by power supplies not up to the spec. Try starting 4 times while true; do true; done &; if your 4A PS is at least 1.5A, it should hold, and the rp should not crash or reboot ;-) – mosvy Dec 25 '19 at 10:51
  • I think the problem is that I was using Dash charger from OnePlus and they have developed a proprietary standard for charging, which is apparently not compatible with the RPI4. – Georgе Stoyanov Dec 27 '19 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.