7

I tried to run

mount /home/user/nvme0n1 -U 8da513ec-20ce-4a2d-863d-978b60089ad3 -t ext4 -o umask=0000

and the response is:

mount: /home/user/nvme0n1: wrong fs type, bad option, bad superblock on /dev/nvme0n1, missing codepage or helper program, or other error.

However, when I remove the umask option, the SSD is mounted as desired. What should I do? How can I start debugging the problem? I want the device to have mode=777.

1 Answer 1

10

You're mounting an ext4 filesystem:

... -t ext4 -o umask=0000

Per the ext4(5) man page, the ext4 filesystem does not have a umask mount option.

I want the device to have mode=777.

If you need different permissions on files and/or directories, you can set file/directory permissions on the files/directories themselves. See What are the different ways to set file permissions etc on gnu/linux.

2
  • Thanks! So if you chmod the directories to be 777, it will appears in boot (assuming we add the corresponding entry to fstab)? Commented Dec 23, 2019 at 11:02
  • 3
    @user3563894 It should be persistent. Just make sure you change the permissions after the file system is mounted. If you change the mountpoint permissions with the file system not mounted, things can get confusing after you mount the filesystem. Commented Dec 23, 2019 at 11:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .