0

I have the goal to compile a gtk version, so I can compile Gimp manually. This is necessary because I use Gimp 2.6, and newer distros only use 2.8 or newer. So I decided to manually compile and old gtk so to be able to compile a gimp 2.6.x.

After an effort that it is even difficult to express in words to be able to compile all the GTK required libraries (with included most of the X library stack), I saw my effort being frustrated by broken compilation attempt with Pango.

GTK requires Pango with X support enabled. And I tried to do so, however, during the make process of Pango compilation (1.8.2 or 1.20.5) with support to X enabled, it generates endless messages like.

For instance with pango 1.20.5 I used these commands before make:

./configure --x-libraries=/media/34GB/Arquivos-de-Programas-Linux/X11-1.6.7/lib/ --x-includes=/media/34GB/Arquivos-de-Programas-Linux/X11-1.6.7/include/ PKG_CONFIG_PATH=/media/34GB/Arquivos-de-Programas-Linux/Fontconfig-2.4.0/lib/pkgconfig/:/media/34GB/Arquivos-de-Programas-Linux/Freetype-2.2.1/lib/pkgconfig/:/media/34GB/Arquivos-de-Programas-Linux/Glib-2.14.6/lib/pkgconfig/ XFT_CFLAGS=/media/34GB/Arquivos-de-Programas-Linux/Xft-2.1.12/include/ XFT_LIBS=/media/34GB/Arquivos-de-Programas-Linux/Xft-2.1.12/lib/

with apparently worked fine.

However during compilation (make) I received endless error messages. SOme of these

../pango/pango-layout.h:253: error: expected declaration specifiers before 'PangoLayoutRun'

/usr/include/_G_config.h:31: error: storage class specified for parameter '_G_fpos64_t' /usr/include/stdio.h:675: error: storage class specified for parameter 'ungetc' ../pango/pango-modules.h:31: error: storage class specified for parameter 'PangoMap'

The error messages are nearly endless. However, the compilation works fine without asking for X and xft support.

The question is.........what can I do? Testing newer pango versions and hoping one works? Trying a newer gtk that might not require Pango with X support enabled?

  • What distro are you using? – ajgringo619 Dec 23 '19 at 1:13
  • Ubuntu 10.04... – user2752471 Dec 23 '19 at 19:29
0

I hope your efforts to better learn linux build systems will not go to waste.

However, a more reasonable solution would be to use a docker image version of some linux distro which had Gimp 2.6 and run it like this:

http://fabiorehm.com/blog/2014/09/11/running-gui-apps-with-docker/

| improve this answer | |
  • I don't understand how this link is useful. My distro does not has this docker stuff. Plus there is the performance implications. – user2752471 Dec 23 '19 at 19:47
  • There are no performance implications, docker is not a virtual machine and runs programs at native speed. – Rafael Kitover Dec 24 '19 at 0:20
  • Am I supposed to run this: RUN apt-get update && apt-get install -y firefox # Replace 1000 with your user / group id RUN export uid=1000 gid=1000 && \ mkdir -p /home/developer && \ echo "developer:x:${uid}:${gid}:Developer,,,:/home/developer:/bin/bash" >> /etc/passwd && \ echo "developer:x:${uid}:" >> /etc/group && \ echo "developer ALL=(ALL) NOPASSWD: ALL" > /etc/sudoers.d/developer && \ chmod 0440 /etc/sudoers.d/developer && \ chown ${uid}:${gid} -R /home/developer – user2752471 Dec 24 '19 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.